Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005729 [JEDI VCL] 00 JVCL Components minor always 2011-12-01 06:27 2013-12-13 11:31
Reporter greg221b View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.45
Summary 0005729: TJvGroupBox styling disappears for all group boxes once a Caption is changed
Description Rounded corners on TJvGroupBoxes, nice colours etc disappear in the compiled application (ie groupbox looks fine in Design tab, but styles vanish when the app is executed) for that and all subsequently added group boxes.
To reproduce:
1) create a new C++ app;
2) create a TJvGroupBox;
3) build & run app;
4) GroupBox whould look fine;
5) in Design tab, change group box caption to anything;
6) build & run app - notice styles have disappeared;
7) styles will be missing on subsequently created group boxes;
8) styles will not return if caption is returned to original.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019174)
greg221b (reporter)
2011-12-05 06:45

Styling also disappears from the following components:
All Jv*Button components;
JvCoolBar;
JvTMTimeLine.
Actually, unless I am missing something fairly obvious, the styling on ALL Jedi VCL components is stuffed. Hmmm.
(0019175)
AHUser (developer)
2011-12-05 23:58

What Delphi version are you using? Are you compiling for 64bit?
I'm not seeing this behavior in D2009/2010/XE/XE2(32bit).
(0019176)
greg221b (reporter)
2011-12-06 00:19

I'm using C++ Builder XE2 (on Windows 7 64bit OS). I'm compiling for 32bit.
I've installed the latest daily build of JCL & JVCL also - all stylings still disappear.
I've checked Delphi XE2 - there are no problems there with styling - I'm guessing this problem is only evident in C++ Builder.
(0019448)
obones (administrator)
2012-02-22 14:53

Any progress here?
(0019971)
obones (administrator)
2012-06-13 16:28

Any news?
(0019983)
greg221b (reporter)
2012-06-13 16:43

No progress - I've tried to spot differences in included object files etc - can't see anything important.
I'm not using any Custom Styles.
I guess I've given up on JVCL - such an enormous problem and it looks like nobody has tried to use it with XE2 and C++ - the problem is pretty obvious.
Thanks anyway.

- Issue History
Date Modified Username Field Change
2011-12-01 06:27 greg221b New Issue
2011-12-05 06:45 greg221b Note Added: 0019174
2011-12-05 23:58 AHUser Note Added: 0019175
2011-12-05 23:58 AHUser Status new => feedback
2011-12-06 00:19 greg221b Note Added: 0019176
2012-02-22 14:53 obones Note Added: 0019448
2012-06-13 16:28 obones Note Added: 0019971
2012-06-13 16:43 greg221b Note Added: 0019983
2013-12-13 11:31 obones Status feedback => resolved
2013-12-13 11:31 obones Resolution open => unable to reproduce
2013-12-13 11:31 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker