Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005744 [JEDI VCL] 00 JVCL Components minor have not tried 2011-12-18 14:47 2012-09-10 14:15
Reporter Kiriakos View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005744: JvProgramVersionCheck incompatibility with 64bit
Description JvProgramVersionsStringList.Sort crashes in 64 bit.

The reason is that the callback procedure VersionNumberSortCompare is declared as a local procedure and Win64 does not like that.

Solution:

Just move VersionNumberSortCompare outside JvProgramVersionsStringList.Sort.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019325)
AHUser (developer)
2012-01-19 20:53

Fixed in svn revision 13190

- Issue History
Date Modified Username Field Change
2011-12-18 14:47 Kiriakos New Issue
2012-01-18 22:42 jfudickar Assigned To => jfudickar
2012-01-19 20:53 AHUser Note Added: 0019325
2012-01-19 20:53 AHUser Status new => resolved
2012-01-19 20:53 AHUser Fixed in Version => Daily / SVN
2012-01-19 20:53 AHUser Resolution open => fixed
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker