Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005749 [JEDI VCL] 00 JVCL Components major always 2011-12-24 14:58 2012-09-10 14:15
Reporter Melloware View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0005749: USB HID Controller makes CPU go to 100% usage
Description I use the USB HID Controller extensively in my application Intelliremote. However certain remotes like the Tivo Slide actually have 6 enumerated HID devices. Each HID device controls a certain subset of buttons on the remote. However if I listen to all 6 devices the CPU spikes to 100% and never comes back down. I can reproduce this every time using the Tivo Slide remote and the demo \Jedi\jvcl\examples\JvHIDController\UsagesDemo

I have a user willing to donate a Tivo Slide to a JEDI developer who wants to debug this so they can see this issue for themselves and what the potential fix may be. I just need to know where to tell him to send the remote?

So basically to reproduce:

1. Plug in and pair the Tivo Slide remote to the PC.

http://support.tivo.com/app/answers/detail/a_id/1788 [^]

2. Run the UsagesDemo and you will see the CPU at 100%.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019292)
zoppa (reporter)
2012-01-03 03:00

Any update on this? I will send a remote to someone who wants to look into this and possible fix it.
(0019457)
obones (administrator)
2012-02-22 15:03

Thank you for your offer, but one would need a Tivo right?
Cause here in Europe, not many of us have a Tivo.

Anyway, can you look in the code and see where the 100% CPU comes from?
It most likely is from a thread that loops very fast without calling any yielding function (sleep, waitforobject...)
(0019462)
zoppa (reporter)
2012-02-22 15:07

No need for Tivo at all. Tivo bluetooth remote is used with Windows media center, but it's not really relevant either. The USB HID bug persists regardless of the app and can be repro-ed with UsagesDemo.
(0019514)
Melloware (reporter)
2012-02-23 12:35

obones,

All you need is the Tivo Remote it plugs in using a USB bluetooth dongle. You won't need anything else. Then in the Usages Demo you will see it spike the CPu to 100%. The Tivo remote this happens the most with but I have seen this behavior with 1 or 2 other USB based remotes.

Thanks for any help you can provide, like Zoppa said he is willing to mail you a Tivo Remote you can just plug in and see! I am sure you will be able to fix the issue.

Thanks! Mello
(0019522)
obones (administrator)
2012-02-24 10:27

Thanks both for your explanations.
zoppa: I'll send you a message to the email you registered here.
(0019754)
Melloware (reporter)
2012-05-13 23:54

obones, Just checking if there is any update on this? Was Zoppa able to get you a Tivo remote to test with?
(0019755)
obones (administrator)
2012-05-14 09:23

Hello,

Unless emails got lost, I'm sorry to say that I never heard back from zoppa.
(0019756)
Melloware (reporter)
2012-05-14 12:18

obones, I have one to send you too if you want to email me your information and I can ship mine.
(0019757)
obones (administrator)
2012-05-14 12:25

Melloware: That's very kind of you, but I wouldn't to deprive you of your tivo remote. I mean, I will most likely not be able to send it back to you after I have used it.
(0019758)
Melloware (reporter)
2012-05-14 13:05

obones: That is OK, i am more interested in getting to the bottom of this tricky bug! I actually only purchased the remote for testing and I don't use it day to day. I would be happy to donate it to the JEDI project.
(0019759)
zoppa (reporter)
2012-05-14 14:33

Gentlemen,

I have never received any emails although I get notifications from this thread just fine.

Please let me know if you have already figured out the remote donation issue, and if not I will just buy one from Amazon and will ship it whomever can look into this.

Best regards,

Daniel S.
(0019768)
Melloware (reporter)
2012-05-20 15:19

obones: we would love to donate a Tivo remote for you to test thing. I know you will be able to see the issue and fix it. It is one of the only bugs ever reported against my software. Send me an email and I will fedex you the remote!
(0019770)
obones (administrator)
2012-05-21 15:44

zoppa: I sent the email back in February, on the 24th to be precise.
Melloware: I don't mind having you send it to me, but I'd prefer that you and zoppa agree on who is sending, I wouldn't want to receive a second one because zoppa has found my previous email.

I have sent a new one to both of you just now.
(0019777)
Melloware (reporter)
2012-05-21 18:13

zoppa, I will handle sending this one to obones. You don't have to worry about it.
(0019779)
obones (administrator)
2012-05-25 09:53

Melloware: I have received the remote just fine yesterday evening, thanks for the shipment.
I plugged the USB receiver, paired the remote using Windows 7's wizard and then I ran the usages demo.
I see 7 entries for TiVo Keyboard Remote, but I don't see the 100% CPU usage, not even a tiny persistent percent.
For instance, on my quad core with hyperthreading, I would expect to see 12.5% CPU usage if the application is misbehaving but here, I only get 0.
There is very little spike when I start the application and when I click on info, but it always comes back down to zero.

I'm using Delphi XE2 and the SVN content as updated on Saturday May 19th 2012, can you check you are using the latest version?

If there are additional steps to see the bug, please let me know
(0019780)
obones (administrator)
2012-05-25 09:55

Hum, trying the other demos, I'm seeing excessive CPU usage using the SimpleHIDWrite demo
(0019781)
obones (administrator)
2012-05-25 10:18

Ok, this is now resolved in SVN, revision 13302

- Issue History
Date Modified Username Field Change
2011-12-24 14:58 Melloware New Issue
2012-01-03 02:58 zoppa Issue Monitored: zoppa
2012-01-03 03:00 zoppa Note Added: 0019292
2012-02-22 15:03 obones Note Added: 0019457
2012-02-22 15:03 obones Status new => feedback
2012-02-22 15:07 zoppa Note Added: 0019462
2012-02-23 12:35 Melloware Note Added: 0019514
2012-02-24 10:27 obones Note Added: 0019522
2012-05-13 23:54 Melloware Note Added: 0019754
2012-05-14 09:24 obones Note Added: 0019755
2012-05-14 12:18 Melloware Note Added: 0019756
2012-05-14 12:25 obones Note Added: 0019757
2012-05-14 13:05 Melloware Note Added: 0019758
2012-05-14 14:33 zoppa Note Added: 0019759
2012-05-20 15:19 Melloware Note Added: 0019768
2012-05-21 15:44 obones Note Added: 0019770
2012-05-21 18:13 Melloware Note Added: 0019777
2012-05-25 09:53 obones Note Added: 0019779
2012-05-25 09:55 obones Note Added: 0019780
2012-05-25 09:55 obones Status feedback => confirmed
2012-05-25 10:18 obones Note Added: 0019781
2012-05-25 10:18 obones Status confirmed => resolved
2012-05-25 10:18 obones Fixed in Version => Daily / SVN
2012-05-25 10:18 obones Resolution open => fixed
2012-05-25 10:18 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker