Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005773 [JEDI VCL] 00 JVCL Components minor always 2012-01-23 08:55 2012-09-10 14:15
Reporter duayfabi View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.40
Summary 0005773: The component <TJvFormStorage> always reload the form size even the option [fpSize] isn't checked
Description I only tested this with a window formstyle set to <bsSingle>.

Steps to reproduce the bug :

- Create a simple project with a single form.
- Set the form's property <BorderStyle> to <bsSingle>.
- Put on the form a TJvAppRegistryStorage component.
- Put on the form a TJvFormStorage component linked with the previous TJvAppRegistryStorage.
- Select the <TJvFormStorage> component and set the <Options> property to [fpSize, fpLocation]
- Compile and run the project. When the application is loaded, note the size of the form.
- Stop the execution of the project and modify the <Options> property of the <TJvFormStorage> component to [fpLocation].
- Modify the size of the form in design mode, recompile and reexecute the application.
- The form have the same size than the first time. The <TJvFormStorage> haven't the option [fpSize] checked but still reload the first size saved.
Additional Information My environment :

Borland Developper Studio 2006
Windows 2003 server 32 bits (tested on Windows 7 too)
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019354)
jfudickar (developer)
2012-01-25 11:22

Which JVCL did you use?

I can't reproduce it with the current svn release and the sample in examples\JvAppStorage\Base Example\

Regards
Jens
(0019368)
duayfabi (reporter)
2012-02-03 15:52

ok, I found what goes wrong! Here a new procedure to follow (delphi 2006 pro, JVCL 3.40) :

1. Create a simple form with only a <TJvFormStorage> and a <TJvAppRegistryStorage> on it.
2. Select the <TJvFormStorage> component and set the <Options> property to [fpSize, fpLocation]
3. Create a child form which inherits from the form created on point 1
4. On the child form, double click on the <TJvFormStorage> and uncheck the <Form size> option.
5. Validate your choice. Sometimes, the checkbox values are saved, sometimes not.

Info : If you use the object inspector to change the <fpSize> property to false, all goes well, only the visual interface don't save correctly the option's value.
(0019380)
jfudickar (developer)
2012-02-10 20:36

Could you create a small sample showing the problems
(0019963)
obones (administrator)
2012-06-13 16:27

We really need a sample application showing this.
(0019985)
duayfabi (reporter)
2012-06-14 10:26

I updated the library with the latest version and I can't reproduce this issue with this version..
(0019988)
obones (administrator)
2012-06-14 11:22

Thanks for letting us know

- Issue History
Date Modified Username Field Change
2012-01-23 08:55 duayfabi New Issue
2012-01-25 11:22 jfudickar Note Added: 0019354
2012-01-25 11:22 jfudickar Status new => feedback
2012-02-03 15:52 duayfabi Note Added: 0019368
2012-02-10 20:36 jfudickar Note Added: 0019380
2012-06-13 16:27 obones Note Added: 0019963
2012-06-14 10:26 duayfabi Note Added: 0019985
2012-06-14 11:22 obones Note Added: 0019988
2012-06-14 11:22 obones Status feedback => resolved
2012-06-14 11:22 obones Fixed in Version => Daily / SVN
2012-06-14 11:22 obones Resolution open => unable to reproduce
2012-06-14 11:22 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker