Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005783 [JEDI VCL] 00 JVCL Components feature always 2012-02-03 22:12 2012-03-12 19:27
Reporter wpostma View Status public  
Assigned To wpostma
Priority low Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005783: Add feature: JV Docking should notify client TForms when they are docked and undocked.
Description From JVCL newsgroups:


I am willing to add the following feature to JvDocking...

Saw this question on StackOverflow:
http://stackoverflow.com/questions/9068016/delphi-jvdockserver-jvdockclient [^]

Problem:
  TForm has events OnUnDock and OnEndDock, but these are not fired when Jedi
JvDocking does a dock or undock operation. There are also no "on dock" or
"on float" events available anywhere in the code. This seems like a design
oversight by the original Chinese Delphi developers who contributed the
original JvDocking code, which I have done some improvements on.

My answer is that JvDocking does not support it, but I can fix it so it
does. Any JVCL devs have an opinion on this? SHould I fix it?

In short, the JvDocking code in JvDockSupportControl.pas needs to check for
Dock Client = TForm, and check if TForm.OnUnDock is assigned, and if so,
fire an event so that the form is notified that it is being undocked. Same
approach will work for Docking.

Additional Information

OBones replied; Go ahead.
Tags No tags attached.
Attached Files

- Relationships
related to 0005023resolvedwpostma ManualTabDock fails to work first time and works incorrectly subsequent times, Dock to Tab Grabber invisibility. 

-  Notes
(0019661)
wpostma (developer)
2012-03-12 19:26

Comitted change as revision 13273
(0019662)
wpostma (developer)
2012-03-12 19:27

Please report any JvDocking issues to me via email warren.postma@gmail.com for quicker attention since I only rarely check mantis or the newsgroup.

- Issue History
Date Modified Username Field Change
2012-02-03 22:12 wpostma New Issue
2012-02-03 22:12 wpostma Assigned To => wpostma
2012-02-22 15:07 obones Status new => confirmed
2012-03-12 19:26 wpostma Note Added: 0019661
2012-03-12 19:27 wpostma Note Added: 0019662
2012-03-12 19:27 wpostma Status confirmed => resolved
2012-03-12 19:27 wpostma Resolution open => fixed
2012-03-12 19:41 wpostma Relationship added related to 0005023


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker