Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005801 [JEDI VCL] 02 Installation major always 2012-02-17 08:39 2012-09-10 14:15
Reporter a-s-z View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0005801: Inconsistent naming / usage of include files
Description Hi,

as mentioned in another report, I have managed to add a custom package using some components depending on DevExpress. The package is using conditionals, like JvDB-R.

Up to Delphi XE, there is no problem with compiling/generating.
When installing for XE2, everything seems to be fine too, but it isn't. Some components/units are missing, even when you activated the corresponding conditional (e.g. USE_3RDPARTY_DEVEXPRESS_CXEDITOR) using the include file suggested by the installer (jvcld16winxx.inc). All units depending on these conditionals are missing in the generated project files (dpk, dproj).

So what is wrong?

JVCLInstall will generate the package files using the conditionals of the current target. Unfortunatly, the package generator (in devtools) uses the target name to build up the file name for the inc file, and this is a different identifier since XE2.

JVCLInstall uses inc file: jvcld16win32.inc / jvcld16win64.inc
Package generator uses inc file: jvcld16.inc / jvcld16_x64.inc

Due to this, the conditionals in jvcld16win32.inc will not be parsed from the package generator and so the packages are generated without the units, depending on these.

Names of the include files should get synced. I suggest usage of package generator scheme (jvcld16.inc / jvcld16_x64.inc), since packages and directory structure follows this scheme too.


Regards,
  Andre
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019432)
jfudickar (developer)
2012-02-17 21:32

Which revision did you use? I thought we have fixed this a long time ago.
(0019433)
a-s-z (reporter)
2012-02-21 07:59

Hi,

I have used JVCL 3.45.

The issue seems to be fixed in SVN. Is there some kind of bugfix branch for 3.45? Or do I have to use current/daily SVN to fix this?

Regards,
  Andre
(0019434)
jfudickar (developer)
2012-02-21 14:52

You can use the svn trunk or you can use the daily zip files.

Regards
Jens

- Issue History
Date Modified Username Field Change
2012-02-17 08:39 a-s-z New Issue
2012-02-17 21:32 jfudickar Note Added: 0019432
2012-02-21 07:59 a-s-z Note Added: 0019433
2012-02-21 14:52 jfudickar Note Added: 0019434
2012-02-22 15:20 obones Status new => resolved
2012-02-22 15:20 obones Fixed in Version => Daily / SVN
2012-02-22 15:20 obones Resolution open => fixed
2012-02-22 15:20 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker