Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005806 [JEDI VCL] 00 JVCL Components major always 2012-02-23 16:57 2012-09-10 14:15
Reporter stevegr View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005806: JvDBGrid - DefaultDrawColumnCell and ShowMemos
Description if ShowMemos is true and an OnDrawColumnCell event is implemented,
data in memo fields are displayed as (Memo) the default behaviour of TDBGrid.

A fix is uploaded,
- DefaultDrawColumnCell
(source JvDBGrid.pas JVCL3-2012-02-22)
Additional Information
Tags No tags attached.
Attached Files ? file icon JvDBGrid.pas [^] (167,834 bytes) 2012-02-23 16:58
7z file icon 2012-02-25.7z [^] (911,099 bytes) 2012-02-25 23:53
? file icon JvDBUltimGrid.pas [^] (28,657 bytes) 2012-02-25 23:58
? file icon JvDBUltimGrid_2012-02-29.pas [^] (28,327 bytes) 2012-02-29 12:51
? file icon JvDBUltimGrid_2012-02-29_2.pas [^] (28,813 bytes) 2012-02-29 13:47

- Relationships
related to 0005664confirmed JvDBGrids MultySelect 
related to 0005662confirmed JvDBGrids.FixedCols 
related to 0005663confirmed JvDBGrids DrawingStyle 
related to 0005610resolvedobones TJvDBGrids, Vertical seperator line on title cells is not displayed. 
related to 0005602acknowledged JvDBGrid, JvDBUltimGrid - DoubleClick sorting problem. 
related to 0005603resolvedobones JvDBUltimGrid - ADO sorting problem. 

-  Notes
(0019521)
obones (administrator)
2012-02-24 10:25

Please provide the zipped sources of a sample application showing this issue.
(0019548)
stevegr (reporter)
2012-02-24 19:49

Updated demo and sources whould be ready to upload this Saturday...
Related: Mantis 0005662
(0019555)
stevegr (reporter)
2012-02-25 23:54

Updated demo and sources uploaded.
(0019560)
obones (administrator)
2012-02-27 11:12

Thanks, this is now in SVN
(0019568)
obones (administrator)
2012-02-27 11:41

Your "updates.txt" file mention changes in JvDBGrid.pas that I could not find in the version attached to this issue.
Could you update your SVN copy and then upload the changes you made?
Namely, I'm speaking of these changes:

- Resize column using double-click.
- When resize do not trigger title double-click event.
- CancelOnMouse property: Cancel current record when using mouse wheel or on column resizing using double-click.
- Move private ShowSelectColumnClick in the protected section.

Ideally, if these are associated to Mantis issue, I'd like the number as well.
Thanks
(0019572)
stevegr (reporter)
2012-02-27 12:09

"updates.txt" containes acumulated all the updates contributed already by Argonet Developer Group. The 4 mentioned above are already part of the JvDBGrid. Sorry for the inconvinience.
(0019576)
obones (administrator)
2012-02-27 12:16

Ok, thanks for confirming.
(0019619)
jfudickar (developer)
2012-02-28 22:31

Hi Steve,

looking at your changes.

Could you please describe the reason and idea of the usage of TClientdataset in this line:
TClientDataSet(DSet).AddIndex(NewIndexName, SortString, [], DescString);

I do not like/understand two things:
1. What happens if a not TClientdataset is used in combination with the grid.
2. We increased the exe size of all applications by including the TClientdatase code.

Any hints are welcome.

Regards
Jens
(0019620)
stevegr (reporter)
2012-02-28 23:39

Hi,

1. swClient sorts only TClentDataSet as swFields works only with ADO tables and swIndex works with BDE tables. Checking is needed for SortWith property however or an exception is fired when combined with the wrong type of dataset.
2. To sort TClentDataSet I used AddIndex property not exist in TDataSet. I look into code to dispose of TClentDataSet reference, hopefully until tommorow.

By the way is anybody interested in exporting dbgrid in LibreOffice?
(0019624)
stevegr (reporter)
2012-02-29 12:50

Code is fixed and uploaded
(0019625)
stevegr (reporter)
2012-02-29 13:51

JvDBUltimGrid_2012-02-29_2.pas contains sample code for dataset class testing before sorting.
(0019627)
obones (administrator)
2012-02-29 15:08

Jens, Steve,

I have added a slightly modified version of the code in SVN, please let me know if it satisfies both of you.

Regards
Olivier
(0019631)
jfudickar (developer)
2012-02-29 23:10

For me it looks much better now.
(0019632)
stevegr (reporter)
2012-03-01 12:44

The modification of exception code looks better. It's ok for me too.
(0019633)
obones (administrator)
2012-03-01 14:09

Excellent, then this bug is resolved

- Issue History
Date Modified Username Field Change
2012-02-23 16:57 stevegr New Issue
2012-02-23 16:58 stevegr File Added: JvDBGrid.pas
2012-02-24 10:25 obones Note Added: 0019521
2012-02-24 10:25 obones Status new => feedback
2012-02-24 19:49 stevegr Note Added: 0019548
2012-02-25 23:53 stevegr File Added: 2012-02-25.7z
2012-02-25 23:54 stevegr Note Added: 0019555
2012-02-25 23:58 stevegr File Added: JvDBUltimGrid.pas
2012-02-27 11:10 obones Relationship added related to 0005664
2012-02-27 11:11 obones Relationship added related to 0005662
2012-02-27 11:11 obones Relationship added child of 0005663
2012-02-27 11:12 obones Note Added: 0019560
2012-02-27 11:12 obones Status feedback => resolved
2012-02-27 11:12 obones Fixed in Version => Daily / SVN
2012-02-27 11:12 obones Resolution open => fixed
2012-02-27 11:12 obones Assigned To => obones
2012-02-27 11:13 obones Relationship deleted child of 0005663
2012-02-27 11:13 obones Relationship added related to 0005663
2012-02-27 11:15 obones Relationship added related to 0005610
2012-02-27 11:15 obones Relationship added related to 0005602
2012-02-27 11:29 obones Relationship added related to 0005603
2012-02-27 11:41 obones Note Added: 0019568
2012-02-27 11:41 obones Status resolved => feedback
2012-02-27 11:41 obones Resolution fixed => reopened
2012-02-27 12:09 stevegr Note Added: 0019572
2012-02-27 12:16 obones Note Added: 0019576
2012-02-27 12:16 obones Status feedback => resolved
2012-02-27 12:16 obones Resolution reopened => fixed
2012-02-28 22:31 jfudickar Note Added: 0019619
2012-02-28 22:31 jfudickar Status resolved => feedback
2012-02-28 22:31 jfudickar Resolution fixed => reopened
2012-02-28 23:39 stevegr Note Added: 0019620
2012-02-29 12:50 stevegr Note Added: 0019624
2012-02-29 12:51 stevegr File Added: JvDBUltimGrid_2012-02-29.pas
2012-02-29 13:47 stevegr File Added: JvDBUltimGrid_2012-02-29_2.pas
2012-02-29 13:51 stevegr Note Added: 0019625
2012-02-29 15:08 obones Note Added: 0019627
2012-02-29 23:10 jfudickar Note Added: 0019631
2012-03-01 12:44 stevegr Note Added: 0019632
2012-03-01 14:09 obones Note Added: 0019633
2012-03-01 14:09 obones Status feedback => resolved
2012-03-01 14:09 obones Resolution reopened => fixed
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker