Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005831 [JEDI VCL] 00 JVCL Components minor always 2012-03-12 22:23 2012-09-10 14:15
Reporter maro48m View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005831: JvTFDays calculates incorrect Rect for Cells to draw
Description Cells in JvTFDays are incorrectly drawn - without lines separating them. When used
with Grouping property - groupings are not drawn at all and title rows are to narrow for caption to fit in.

For me it was a show stopper for JvTFDays
Additional Information Line 5153 has incorrect variables used after abandoning
with Rect do
begin
[...]
end;
block in rev 13104

this line is
  Rect.Bottom := Top + RowHeight;
and should be:
  Rect.Bottom := Rect.Top + RowHeight;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019840)
obones (administrator)
2012-06-11 17:22

Please provide the zipped sources of a sample application showing this.
(0019938)
maro48m (reporter)
2012-06-12 18:30

there's no need for my source.
Example provided with JVCL will do fine:)
(0019940)
obones (administrator)
2012-06-13 09:28

Then I need detailed instructions as I'm not seeing it at first glance.
(0019984)
maro48m (reporter)
2012-06-13 20:47

1. In Days page, change combobox option from Single to Group.
2. click "open eye" button and select all shedules
3. go to 2002-01-02 data

Result should look like this:
http://img600.imageshack.us/img600/3935/daysokk.png [^]

but looks like this:
http://img137.imageshack.us/img137/9454/daysbad.png [^]
(0019990)
obones (administrator)
2012-06-14 12:30

Thanks, this is now solved in SVN

- Issue History
Date Modified Username Field Change
2012-03-12 22:23 maro48m New Issue
2012-06-11 17:22 obones Note Added: 0019840
2012-06-11 17:22 obones Status new => feedback
2012-06-12 18:30 maro48m Note Added: 0019938
2012-06-13 09:28 obones Note Added: 0019940
2012-06-13 20:47 maro48m Note Added: 0019984
2012-06-14 12:30 obones Note Added: 0019990
2012-06-14 12:30 obones Status feedback => resolved
2012-06-14 12:30 obones Fixed in Version => Daily / SVN
2012-06-14 12:30 obones Resolution open => fixed
2012-06-14 12:30 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker