Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005833 [JEDI VCL] 00 JVCL Components major always 2012-03-15 14:23 2012-09-10 14:15
Reporter cadsky View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.40
Summary 0005833: TJvMemoryData fails to store empty string. You will always get null
Description PAS:
  JvMemoryData1.open;
  JvMemoryData1.Append;
  JvMemoryData1['Field1'] := ''; // TStringField or TWideStringField
  Assert(JvMemoryData1['Pole1']=''); // Assertion failure


DFM:
  object JvMemoryData1: TJvMemoryData
    Left = 144
    Top = 152
    object JvMemoryData1Field1: TStringField
      FieldName = 'Field1'
    end
  end
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019672)
AHUser (developer)
2012-03-15 21:07

Fixed in svn revision 14275.
I've added a new property TrimEmptyString: Boolean default True. If you set it to False, the JvMemoryData will return the string value that you put into it. I have made True the default because this was the behavior of the component for years and user code may depend on that Oracle-like behavior.

- Issue History
Date Modified Username Field Change
2012-03-15 14:23 cadsky New Issue
2012-03-15 21:07 AHUser Note Added: 0019672
2012-03-15 21:07 AHUser Status new => resolved
2012-03-15 21:07 AHUser Fixed in Version => Daily / SVN
2012-03-15 21:07 AHUser Resolution open => fixed
2012-03-15 21:07 AHUser Assigned To => AHUser
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker