Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005873 [JEDI VCL] 00 JVCL Components minor always 2012-05-02 15:43 2013-12-13 11:23
Reporter AceVice View Status public  
Assigned To obones
Priority normal Resolution suspended  
Status resolved   Product Version
Summary 0005873: JvSwitch and Enable handling
Description I have detected the following behaviour in JvSwitch when you set "Enable" to "False":

1- You can click (or use ToggleKey) over the component, so you can change its value (¿?)

2- With some Glyphs, when "CreateDisabledBitmap" does not make well his job, the component is not visible at all
Additional Information The first problem is due to methods "MouseDown" and "KeyDown", they should also check Enabled value, ie:

MouseDown:
----------
  ...
  if Enabled and (Button = mbLeft) then begin
  ...

KeyDown:
--------

  ...
  if Enabled and (FToggleKey = ShortCut(Key, Shift)) then begin
  ...


The second problem occurs with some kind of bitmaps (uploaded like attachment), it seems that "CreateDisabledBitmap" does not transform them well, so the final result is an invisible component; possible fixes:

  - Review "CreateDisabledBitmap"
  - Option to use standard Glyph (GlyphOn/GlyphOff) in all cases.

Paint:
-----

  ...
  if not Enabled and (FDisableBitmaps[FStateOn] <> nil) then
    DrawBitmap(FDisableBitmaps[FStateOn])
  else
    DrawBitmap(FBitmaps[FStateOn]);
  ...

Tags No tags attached.
Attached Files rar file icon Glyps.rar [^] (552 bytes) 2012-05-02 15:43

- Relationships

-  Notes
(0019864)
obones (administrator)
2012-06-11 17:32

Please use the latest SVN version and provide the zipped sources of a sample application showing this.
(0020770)
obones (administrator)
2013-12-13 11:23

No news, suspending the issue

- Issue History
Date Modified Username Field Change
2012-05-02 15:43 AceVice New Issue
2012-05-02 15:43 AceVice File Added: Glyps.rar
2012-06-11 17:32 obones Note Added: 0019864
2012-06-11 17:32 obones Status new => feedback
2013-12-13 11:23 obones Note Added: 0020770
2013-12-13 11:23 obones Status feedback => resolved
2013-12-13 11:23 obones Resolution open => suspended
2013-12-13 11:23 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker