Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005878 [JEDI VCL] 00 JVCL Components major have not tried 2012-05-08 20:54 2013-12-13 11:24
Reporter limagito View Status public  
Assigned To obones
Priority normal Resolution suspended  
Status resolved   Product Version 3.45
Summary 0005878: TJvAppDBStorage doesn't store empty strings
Description You can't store empty strings using the TJvAppDBStorage
Additional Information JvAppDBStorage.pas

function TJvCustomAppDBStorage.DoReadString(const Path: string;
  const Default: string): string;
var
  Section: string;
  Key: string;
begin
  SplitKeyPath(Path, Section, Key);
  Result := ReadValue(Section, Key);
  //THE REASON IS THE FOLLOWING 2 LINES OF CODE
  if Result = '' then
    Result := Default;
end;

Should be:

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019746)
limagito (reporter)
2012-05-08 21:12

Should be:

function TJvCustomAppDBStorage.DoReadString(const Path: string;
  const Default: string): string;
var
  Section: string;
  Key: string;
begin
  SplitKeyPath(Path, Section, Key);
  if ValueExists(Section, Key, False) then
    Result := ReadValue(Section, Key)
  else
    Result := Default;
end;
(0019867)
obones (administrator)
2012-06-11 17:33

Please use the latest SVN version and provide the zipped sources of a sample application showing this.
(0020773)
obones (administrator)
2013-12-13 11:24

No news, suspending the issue

- Issue History
Date Modified Username Field Change
2012-05-08 20:54 limagito New Issue
2012-05-08 21:12 limagito Note Added: 0019746
2012-06-11 17:33 obones Note Added: 0019867
2012-06-11 17:33 obones Status new => feedback
2013-12-13 11:24 obones Note Added: 0020773
2013-12-13 11:24 obones Status feedback => resolved
2013-12-13 11:24 obones Resolution open => suspended
2013-12-13 11:24 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker