Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005882 [JEDI VCL] 00 JVCL Components block always 2012-05-15 22:25 2012-06-11 17:35
Reporter Eduardo Mauro View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version 3.45
Summary 0005882: AssignRecord is does not copy NULL values
Description Function AssignRecord was broken in revision 12972. In the prior version, values were copied as variant, so NULL values were copied correctly. In revision 12972, values are copied using its type. For instance, DateTime fields are copied using AsDateTime. Doing so null dates are converted to 0.
Additional Information
Tags JvDBUtils
Attached Files

- Relationships
duplicate of 0005804resolvedobones TJvMemory LoadFromDataset does not copy Null Value 
duplicate of 0005887resolvedobones TJvDBGrid displays NULL in DateTime field as 30.12.1899 

-  Notes
(0019795)
Eduardo Mauro (reporter)
2012-05-31 14:50

Same as 0005804

- Issue History
Date Modified Username Field Change
2012-05-15 22:25 Eduardo Mauro New Issue
2012-05-15 22:26 Eduardo Mauro Tag Attached: JvDBUtils
2012-05-15 22:26 Eduardo Mauro Issue Monitored: Eduardo Mauro
2012-05-31 14:50 Eduardo Mauro Note Added: 0019795
2012-06-11 17:34 obones Relationship added duplicate of 0005804
2012-06-11 17:35 obones Relationship added duplicate of 0005887
2012-06-11 17:35 obones Status new => resolved
2012-06-11 17:35 obones Resolution open => duplicate
2012-06-11 17:35 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker