Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005888 [JEDI VCL] 00 JVCL Components minor always 2012-05-21 18:03 2012-09-10 14:15
Reporter sourcemaker View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005888: MessageDlg DefaultButton did not work as before
Description If I set the DefaultButton then I assume that the Button get the Focus.
This works in some older versions.
In the newer version DefaultButton is only for the timerevent.

I use DefaultButton to set the Default-Choice for the user and sometimes for timerevent.

Line: 981
      if I = DefaultButton then
        ResultForm.DefaultButton := Button;
// Button.Default := True;

can be:
      if I = DefaultButton then
      begin
        ResultForm.DefaultButton := Button;
        Button.Default := True;
      end;

The possibilty from the older version was one of the reason to use them.
Additional Information
Tags No tags attached.
Attached Files zip file icon Defaultbutton.zip [^] (5,914 bytes) 2012-06-12 10:56

- Relationships

-  Notes
(0019869)
obones (administrator)
2012-06-11 17:34

Please provide the zipped sources of a sample application showing this.
(0019898)
sourcemaker (reporter)
2012-06-12 11:07

I forget the unit name - JvDSADialogs and the line is 989 in build 4197.
(0019942)
obones (administrator)
2012-06-13 10:53

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2012-05-21 18:03 sourcemaker New Issue
2012-06-11 17:34 obones Note Added: 0019869
2012-06-11 17:34 obones Status new => feedback
2012-06-12 10:56 sourcemaker File Added: Defaultbutton.zip
2012-06-12 11:07 sourcemaker Note Added: 0019898
2012-06-12 17:56 obones Status feedback => acknowledged
2012-06-13 10:53 obones Note Added: 0019942
2012-06-13 10:53 obones Status acknowledged => resolved
2012-06-13 10:53 obones Fixed in Version => Daily / SVN
2012-06-13 10:53 obones Resolution open => fixed
2012-06-13 10:53 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker