Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005891 [JEDI VCL] 00 JVCL Components minor always 2012-05-31 15:01 2015-09-21 17:47
Reporter thomasg_76 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005891: JvColorBotton shows JvColorForm off screen or behind the windows task bar
Description If a JvColorBotton is placed very near the window task bar or very close to the bottom of the screen (workable area) then the JvColorForm is drawn partially outside an area the user can click.
The user then to circumvent the situation by resizing the application so that the form can be fully shown.
Additional Information I changed the the code in JvColorForm to account for this. I attach the diff generated from SVN so that you can look if the patch will work.
Tags No tags attached.
Attached Files ? file icon JvColorForm.pas.diff [^] (1,016 bytes) 2012-05-31 15:01
jpg file icon TJvColorButton-Current.jpg [^] (14,191 bytes) 2012-06-29 01:23
jpg file icon TJvColorButton-Expected.jpg [^] (19,507 bytes) 2012-06-29 01:24
zip file icon TJvColorButton-Bug.zip [^] (17,784 bytes) 2012-06-29 01:25

- Relationships

-  Notes
(0019870)
obones (administrator)
2012-06-11 17:35

Please use the latest SVN version and provide the zipped sources of a sample application showing this.
(0020042)
thomasg_76 (reporter)
2012-06-29 01:27

The source is not too much a help, so I put 2 screen shots up, showing the current behavior from the SVN code, and the behavior a user would expect (my fix in the diff file).

The issue is really if for some reason the TJvColorButton is near the bottom of the screen, as shown in my screen shots.

By the way the TJvOfficeColorButton has the correct behavior.
(0020835)
obones (administrator)
2013-12-13 16:20

This is now in GIT

- Issue History
Date Modified Username Field Change
2012-05-31 15:01 thomasg_76 New Issue
2012-05-31 15:01 thomasg_76 File Added: JvColorForm.pas.diff
2012-06-11 17:35 obones Note Added: 0019870
2012-06-11 17:35 obones Status new => feedback
2012-06-29 01:23 thomasg_76 File Added: TJvColorButton-Current.jpg
2012-06-29 01:24 thomasg_76 File Added: TJvColorButton-Expected.jpg
2012-06-29 01:25 thomasg_76 File Added: TJvColorButton-Bug.zip
2012-06-29 01:27 thomasg_76 Note Added: 0020042
2013-12-13 11:34 obones Status feedback => acknowledged
2013-12-13 16:20 obones Note Added: 0020835
2013-12-13 16:20 obones Status acknowledged => resolved
2013-12-13 16:20 obones Fixed in Version => Daily / GIT
2013-12-13 16:20 obones Resolution open => fixed
2013-12-13 16:20 obones Assigned To => obones
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker