Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005949 [JEDI VCL] 00 JVCL Components major always 2012-08-06 12:23 2012-09-10 14:15
Reporter moore View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005949: JvControls issues with VCL Styles enabled
Description In the uploaded project some controls do not paint correctly with some skin of VCL Styles enabled, namely JvSpeedButton, JvStatusBar, JvLabel etc.
Additional Information
Tags No tags attached.
Attached Files zip file icon Projects.zip [^] (1,001,856 bytes) 2012-08-06 12:23

- Relationships

-  Notes
(0020074)
moore (reporter)
2012-08-06 12:27

Forgot to say that Delphi version is XE2 update 4..
(0020085)
AHUser (developer)
2012-08-12 01:20

Most of the issues are due to bugs in the VCL's Style-Engine, like unimplemented functions (DrawThemeTextEx), changing GDI objects under the hood (WM_ERASEBKGND hook) or not painting TGraphicControls (TStyleStatusBarHook.Paint doesn't call PaintControls).

Workarounds added in svn revision 13392.

- Issue History
Date Modified Username Field Change
2012-08-06 12:23 moore New Issue
2012-08-06 12:23 moore File Added: Projects.zip
2012-08-06 12:27 moore Note Added: 0020074
2012-08-12 01:20 AHUser Note Added: 0020085
2012-08-12 01:20 AHUser Status new => resolved
2012-08-12 01:20 AHUser Fixed in Version => Daily / SVN
2012-08-12 01:20 AHUser Resolution open => fixed
2012-08-12 01:20 AHUser Assigned To => AHUser
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker