Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005950 [JEDI VCL] 00 JVCL Components minor always 2012-08-06 13:16 2013-08-24 18:36
Reporter mayaopperman View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0005950: TjvFormStorage is still not remembering maximised state for MDIClient forms
Description Originally reported with Delphi XE. http://issuetracker.delphi-jedi.org/view.php?id=5811#c19566 [^]

I was told it was resolved in Jedi Version 3.45.

I have now upgraded to Delphi XE2, and have installed the latest Jedi available, namely 3.45.

There is still no change.

Dropping a TjvFormStorage on an MDIClient does not remember the maximised state.

Additional Information (running XE2 on Windows 7 Ultimate 64 bit)
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020076)
Arioch (developer)
2012-08-06 15:26

where did u obtain that 3.45 ?

zip on https://sourceforge.net/projects/jvcl/files/ [^] was released 2011-11-04

0005811 told you to use SVN to get latest, and the comment was of 2012-02-27

I guess you have to use post-3.45 non-yet-released code.

I use SVN, u may try daily tarballs, but SVN better
(0020541)
jfudickar (developer)
2013-06-25 23:39

Could you provide a sample for this.
In my app it seems to work.
(0020542)
mayaopperman (reporter)
2013-06-26 07:36

>>I use SVN, u may try daily tarballs, but SVN better

Ah, this might explain why I have been tearing my hair out with Jedi lately.

I always use SourceForge for my installation.

I recently upgraded to XE4, and the SourceForge one does not support XE4 yet, so I went with the unstable daily zip that I found a reference to on a forum post.

Where do I get the SVN???
(0020543)
Arioch (developer)
2013-06-26 08:58
edited on: 2013-06-26 09:01

http://jvcl.sf.net [^] -> Downloads -> SVN -> Current development

Dunno though if it supports XE4 or not, personally stopped at XE2

There's also https://github.com/project-jedi/jvcl [^] but i do not remember hearing about official JVCL switch, only about JCL.
jfudikar ?

(0020544)
jfudickar (developer)
2013-06-26 09:34

Don't use the SVN.

The JCL/JVCL is switched to github.

You can also use the daily zip's. They are now filled from the git repository.

http://jvcl.sf.net/daily [^]
http://jcl.sf.net/daily/ [^]

JCL + JVCL are XE4 prepared

Regards
Jens
(0020545)
svk12345 (reporter)
2013-06-27 17:41

Dear developers ! Correct an error, please, in Jcl 2.5 installer

"CodeGear Delphi for Win32 compiler version 18.5
Copyright (c) 1983,2007 CodeGear
Fatal: F2039 Could not create output file 'C:\Documents and Settings\KOVALEV\_R? ¤R??¬_-??\RAD Studio\5.0\Bpl\Jcl110.bpl'
Compilation failure
...failed."

I use Win XP Rus. I use Win XP Rus. The "My Documents" folder in an operating system ALWAYS in LOCAL language (in Russian) !

Regards
Serg
(0020546)
jfudickar (developer)
2013-06-27 17:49

Hi Serg,

Please create a separate issue for this.
Thos problem has nothing to do with the problem of thia issue.

Regards
Jens
(0020597)
jfudickar (developer)
2013-08-24 18:36

No reaction, and I can't reproduce, so I close the issue

- Issue History
Date Modified Username Field Change
2012-08-06 13:16 mayaopperman New Issue
2012-08-06 15:26 Arioch Note Added: 0020076
2012-08-06 15:27 Arioch Status new => feedback
2013-06-25 23:39 jfudickar Note Added: 0020541
2013-06-26 07:36 mayaopperman Note Added: 0020542
2013-06-26 08:58 Arioch Note Added: 0020543
2013-06-26 08:59 Arioch Note Edited: 0020543
2013-06-26 09:01 Arioch Note Edited: 0020543
2013-06-26 09:34 jfudickar Note Added: 0020544
2013-06-27 17:41 svk12345 Note Added: 0020545
2013-06-27 17:49 jfudickar Note Added: 0020546
2013-08-24 18:36 jfudickar Note Added: 0020597
2013-08-24 18:36 jfudickar Status feedback => resolved
2013-08-24 18:36 jfudickar Resolution open => fixed
2013-08-24 18:36 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker