Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005963 [JEDI VCL] 00 JVCL Components minor have not tried 2012-08-23 09:41 2013-12-13 11:15
Reporter Arioch View Status public  
Assigned To obones
Priority normal Resolution won't fix  
Status resolved   Product Version Daily / GIT
Summary 0005963: should we remove trayicon ?
Description TrayIcon component was devised in RxLib for Delphi 1 to 4

AFAIR since Delphi 5 there is stock tray icon component.
And prior Delphi versions are no more supported.

It is also told to work more compatible way in network configurations.

http://stackoverflow.com/questions/12037296 [^]

Would it better be removed ?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020125)
AHUser (developer)
2012-08-24 00:41

Are you sure that Delphi 5 had a TTrayIcon. My source tells me that it was introduced in Delphi 2006 (http://edn.embarcadero.com/article/33415 [^] - The New TTrayIcon Component in BDS 2006)
(0020126)
Arioch (developer)
2012-08-24 09:24

I did not fired it for 2 years, so i am not sure.
In general, i remember that when D5 was out, it seemed to me they clones many RxLib components, like AppEvents.

I had impression that TrayIcon was on the list as well. I may be wrong.
And now 2006 is the most old version that i have access to.
(0020127)
jediuser9999 (reporter)
2012-08-24 09:56

proposal for handling this case:
-because in such cases interesting code constructs could be comprized,
making a "historic"-JVCL-compartment (tabsheet) which the user can
optionally install ( or not, by checking in installer,) could be a solution.
(0020128)
Arioch (developer)
2012-08-24 10:26

Well there is archive folder already :-)

But it is only filled in large rare restructuring events, like JVCL 2 -> 3

I proposed JvDeprecated unit with clear dates of final removal, but no one found it worth it. Maybe it was too using newer Delphi features, and since D7 compatibility is treated essential, or whatever.
(0020757)
obones (administrator)
2013-12-13 11:15

Thing is, TJvTrayIcon provides balloon hints to IDE versions that don't have it.
I'm not sure when it has been added to TTrayICon, but it happened quite late.

- Issue History
Date Modified Username Field Change
2012-08-23 09:41 Arioch New Issue
2012-08-24 00:41 AHUser Note Added: 0020125
2012-08-24 00:41 AHUser Status new => feedback
2012-08-24 09:24 Arioch Note Added: 0020126
2012-08-24 09:56 jediuser9999 Note Added: 0020127
2012-08-24 10:26 Arioch Note Added: 0020128
2013-12-13 11:15 obones Note Added: 0020757
2013-12-13 11:15 obones Status feedback => resolved
2013-12-13 11:15 obones Resolution open => won't fix
2013-12-13 11:15 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker