Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005968 [JEDI VCL] 00 JVCL Components trivial always 2012-08-28 12:32 2012-09-10 14:15
Reporter DeathMAD View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0005968: Error in TJvEditorStrings.InsertText Unicode related
Description Adding garbage symbols in this code

  // line is too small -> expand it with spaces
  Len := Length(BegLine);
  if Len < X then
  begin
   SetLength(BegLine, X - 1);
   FillChar(BegLine[Len + 1], X - Len - 1, ' ');
 end;

In Unicode Delphi FillChar is not correct, because addressed bytes not chars.
Additional Information Solution.

Replace code with this.

 Len := Length(BegLine);
  if Len < X then
    BegLine := StringOfChar(' ', X -1);
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020132)
AHUser (developer)
2012-08-28 21:30

Fixed in svn revision 13407.

- Issue History
Date Modified Username Field Change
2012-08-28 12:32 DeathMAD New Issue
2012-08-28 21:30 AHUser Note Added: 0020132
2012-08-28 21:30 AHUser Status new => resolved
2012-08-28 21:30 AHUser Fixed in Version => Daily / SVN
2012-08-28 21:30 AHUser Resolution open => fixed
2012-08-28 21:30 AHUser Assigned To => AHUser
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker