Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006006 [JEDI VCL] 00 JVCL Components minor always 2012-10-05 16:09 2013-12-13 11:17
Reporter Thermalcake2 View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version Daily / GIT
Summary 0006006: TJvPopupMenu: When using glyphs popup menu is not drawn in native style
Description Windows 7, Delphi 7, SVN version of JCL and JVCL.

1. Create some menus in TJvPopupMenu and glyphs in TImageList.
2. Assign your newly created TImageList with Images in TJvPopupMenu.
3. Assign some ImageIndexes to menu items.
4. Run your program and popup the menu.

See? Your menu looks nothing like a native Windows 7 menu. Now unassign Images from TJvPopupMenu and run your progam. Now the menu looks like a native Windows 7 menu. Can you fix that? Screenshot attached.
Additional Information
Tags No tags attached.
Attached Files jpg file icon screenshot.jpg [^] (15,230 bytes) 2012-10-05 16:09

- Relationships

-  Notes
(0020364)
obones (administrator)
2013-01-15 15:44

Please use the XP painter for this

- Issue History
Date Modified Username Field Change
2012-10-05 16:09 Thermalcake2 New Issue
2012-10-05 16:09 Thermalcake2 File Added: screenshot.jpg
2013-01-15 15:44 obones Note Added: 0020364
2013-01-15 15:44 obones Status new => feedback
2013-12-13 11:17 obones Status feedback => resolved
2013-12-13 11:17 obones Resolution open => unable to reproduce
2013-12-13 11:17 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker