Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006007 [JEDI VCL] 02 Installation crash always 2012-10-08 19:21 2012-10-08 20:10
Reporter dougwoodrow View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006007: (D7) Installer error: "Fatal: File not found: 'System.Types.dcu'
Description Just trying to install the JVCL components in Delphi 7, I get the same error as reported in
http://issuetracker.delphi-jedi.org/view.php?id=5993 [^] (which claims to be resolved):

D:\Delphi\3\Jedi\jvcl\devtools\PackagesGenerator\GenerateDefines.pas(46)
Fatal: File not found: 'System.Types.dcu'

This is with the latest version JVCL347CompleteJCL241-Build4571.zip that is supposed to have fixed the problem.

PS It would be useful if the issuetracker gave details of how the issue was resolved, so we could easily check why it's not working for a specific version of the compiler.

Also, I had to select product version "Daily / SVN" because version 3.47 isn't available.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020250)
AHUser (developer)
2012-10-08 19:45

The issue was solved by removing the "System." namespace prefix.
(0020251)
dougwoodrow (reporter)
2012-10-08 20:04

Many thanks, that worked. :)

- Issue History
Date Modified Username Field Change
2012-10-08 19:21 dougwoodrow New Issue
2012-10-08 19:45 AHUser Note Added: 0020250
2012-10-08 20:04 dougwoodrow Note Added: 0020251
2012-10-08 20:10 AHUser Status new => resolved
2012-10-08 20:10 AHUser Resolution open => fixed
2012-10-08 20:10 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker