Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006017 [JEDI VCL] 02 Installation block always 2012-10-19 17:00 2012-11-05 10:36
Reporter igorhx View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version Daily / GIT
Summary 0006017: Application fails with "JvJVCLUtils was compiled with a different version of Vcl.Grids.CustomGrid"
Description The package JVCL347CompleteJCL241-Build4571.zip from 2012-09-11 is installed properly without any error, but any 32bit application using JVCL fails on compile:
[dcc32 Fatal Error] Main.pas(17): F2051 Unit JvJVCLUtils was compiled with a different version of Vcl.Grids.TCustomGrid

Details:
*Embarcadero® Delphi® XE3 Version 17.0.4625.53395, Professional
*Windows 7 Ultimate x64 Service Pack 1 with all available updates until now
*JCL 2.4 Release Build 4571 from the mentioned zip package, installed with default settings in both 32bit and 64bit modes (just the BPL/DCP paths modified)
*JVCL 3.47.0.0 from the mentioned zip package, installed with default settings in both 32bit and 64bit modes

Computer was checked for presence of JvJVCLUtils.dcu, it's just in one place - JVCL\lib\d17\win32 directory for 32bit, JVCL\lib\d17\win64 for 64bit.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020296)
obones (administrator)
2012-11-05 10:36

That's most likely because your 32bits search paths are referring to x64 paths

- Issue History
Date Modified Username Field Change
2012-10-19 17:00 igorhx New Issue
2012-11-05 10:36 obones Note Added: 0020296
2012-11-05 10:36 obones Status new => resolved
2012-11-05 10:36 obones Resolution open => unable to reproduce
2012-11-05 10:36 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker