Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006043 [JEDI VCL] 00 JVCL Components minor always 2012-12-03 14:09 2013-01-15 16:03
Reporter gta View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version 3.39
Summary 0006043: TJvDBLookupTreeViewCombo searching with national characters UTF (with bugfix)
Description
in function TJvDBLookupControl.ProcessSearchKey searching is limited to
characters from range: VK_SPACE..255:
For Delphi >= 2009 char type takes 2 bytes so it gets values greater than 255.



Here is a bug fix:

 +++ OLD VERSION (CURRENT VERSION) +++
procedure TJvDBLookupControl.ProcessSearchKey(Key: Char);
var
  TickCount: Integer;
  S: string;
begin
  if (FListField <> nil) and (FListField.FieldKind = fkData) and
    ((FListField.DataType = ftString) or (FListField.DataType = ftWideString)) then
    case Word(Key) of
      VK_BACK, VK_ESCAPE:
        FSearchText := '';
      VK_SPACE..255:
        if CanModify then
        begin
          TickCount := GetTickCount;
          if TickCount - FSearchTickCount > 2000 then
     (...)
end;




 +++ NEW VERSION (WITHOUT BUG) +++
procedure TJvDBLookupControl.ProcessSearchKey(Key: Char);
var
  TickCount: Integer;
  S: string;
begin
  if (FListField <> nil) and (FListField.FieldKind = fkData) and
    ((FListField.DataType = ftString) or (FListField.DataType = ftWideString)) then
    case Word(Key) of
      VK_BACK, VK_ESCAPE:
        FSearchText := '';
      // VK_SPACE..255:
      VK_SPACE..Word(High(Char)):
        if CanModify then
        begin
          TickCount := GetTickCount;
          if TickCount - FSearchTickCount > 2000 then
     (...)
end;
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0006042resolvedobones TJvDBLookupCombo searching with national characters UTF (with bugfix) 

-  Notes
(0020378)
obones (administrator)
2013-01-15 16:03

Duplicate

- Issue History
Date Modified Username Field Change
2012-12-03 14:09 gta New Issue
2013-01-15 16:03 obones Note Added: 0020378
2013-01-15 16:03 obones Relationship added duplicate of 0006042
2013-01-15 16:03 obones Duplicate ID 0 => 6042
2013-01-15 16:03 obones Status new => resolved
2013-01-15 16:03 obones Resolution open => duplicate
2013-01-15 16:03 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker