Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006045 [JEDI VCL] 00 JVCL Components minor always 2012-12-05 12:03 2015-09-14 13:20
Reporter ssslab View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006045: Incorrect fix of the issue "Mantis 5818" in JvDBGrid.pas again
Description When you try to resize partially displayed last colums it will always resize near left fully displayed column.

Maybe the right code would be :

  if Index > LeftCol + VisibleColCount then
    Index := LeftCol + VisibleColCount;

I think you should use the LeftCol property instead of the FirstVisibleColumn. Because the LeftCol property is also used in the TCustomGrid.GetVisibleColCount function.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020379)
obones (administrator)
2013-01-15 16:05

Please provide the zipped sources of a sample application showing this.
(0020512)
AHUser (developer)
2013-05-25 16:10

Fixed in svn revision 13517.

- Issue History
Date Modified Username Field Change
2012-12-05 12:03 ssslab New Issue
2013-01-15 16:05 obones Note Added: 0020379
2013-01-15 16:05 obones Status new => feedback
2013-05-25 16:10 AHUser Note Added: 0020512
2013-05-25 16:10 AHUser Status feedback => resolved
2013-05-25 16:10 AHUser Fixed in Version => Daily / SVN
2013-05-25 16:10 AHUser Resolution open => fixed
2013-05-25 16:10 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker