Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006049 [JEDI VCL] 00 JVCL Components major always 2012-12-20 07:35 2013-12-13 15:29
Reporter AndrewTrohins View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version 3.47
Summary 0006049: JvMemoryData.SortOnFields error 'No data found' when JvMemoryData linking with DBGrid
Description If i use link JvMemoryData->DataSource->DBGrid, then
exception 'No data found' generated when call SortOnFields.
If I delete link with DBGrid, it work's.

Example:
DataSet->KeyFieldNames = "ID";
DataSet->Open();
DataSet->Append();
DataSet->FieldValues["ID"] = 1;
DataSet->FieldValues["TITLE"] = "Test";
DataSet->Post();
DataSet->SortOnFields("TITLE",true,false);

Please, help.
Additional Information
Tags No tags attached.
Attached Files rar file icon TestJvMemoryData.rar [^] (83,245 bytes) 2012-12-20 07:35

- Relationships
duplicate of 0006041feedback JvMemoryData SortOnFields don't work 

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-12-20 07:35 AndrewTrohins New Issue
2012-12-20 07:35 AndrewTrohins File Added: TestJvMemoryData.rar
2012-12-20 07:38 AndrewTrohins Issue Monitored: AndrewTrohins
2013-01-15 16:08 obones Status new => acknowledged
2013-12-13 15:29 obones Relationship added duplicate of 0006041
2013-12-13 15:29 obones Duplicate ID 0 => 6041
2013-12-13 15:29 obones Status acknowledged => resolved
2013-12-13 15:29 obones Resolution open => duplicate
2013-12-13 15:29 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker