Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006053 [JEDI VCL] 00 JVCL Components major always 2012-12-26 02:35 2013-12-16 17:05
Reporter leus View Status public  
Assigned To obones
Priority normal Resolution suspended  
Status resolved   Product Version 3.47
Summary 0006053: Exception: "CSV string is too long" with non-escaped lines containing internal quotes
Description Trying to import a simple CSV file (separated by semicolon) and get an exception on a line with a double quote inside a column:

CSV string is too long: 78494010-1;SOC COMERCIAL O"HIGGINS LIMIT.

I've attached a project that reproduces the issue. In the Delphi IDE try to change the dataset Active property to true and you should get the exception.

I've added MadExcept's information.
Additional Information Removed by reporter's request
Tags No tags attached.
Attached Files zip file icon test_csv.zip [^] (490,458 bytes) 2012-12-26 02:35

- Relationships
has duplicate 0006149closed TJvCSVDataSet : Error String too long. 

-  Notes
(0020321)
leus (reporter)
2012-12-26 02:36

Hm, sorry for the spam - didn't notice how verbose MadExcept is.
(0020382)
obones (administrator)
2013-01-15 16:09

Double quotes should be escaped, having them like that is a sure way to wreak havoc
(0020394)
leus (reporter)
2013-01-16 05:30

A double quote located anywhere but right at the beginning of a new column shouldn't have any special meaning. If it does, it is a bug.
(0020395)
leus (reporter)
2013-01-16 05:31

By the way, is it possible to remove the "Additional information" field? It is shameful (and full of private information!)
(0020608)
Arioch (developer)
2013-08-31 03:52
edited on: 2013-08-31 03:56

Can you just press "Edit" button to the left down from the list of attached files ?

----

http://tools.ietf.org/html/rfc4180 [^]

 If fields are not enclosed with double quotes, then
        double quotes may not appear inside the fields.

(0020629)
leus (reporter)
2013-09-02 17:17

Ok, not a bug. Is it possible to make it support it anyways? Excel consumes and creates this file without problems. I'll take a look but I remember getting lost in the source last time.
(0020632)
Arioch (developer)
2013-09-03 08:17

Good luck. TDataSet internals are a very complicated thing, i remember it from my TDbf days.

Now that Joanna Carter removed Delphi articles from her site, including DS internal mechanics review, that would be quite a task for you.
(0020801)
obones (administrator)
2013-12-13 11:46

So, what do we do here? Simply resolve as "not fixable" ?
(0020807)
Arioch (developer)
2013-12-13 12:13

I'd close as "postponed" or what that is in English. If someone would implement - he is welcome to add patch here. If no one would - then be it.

It is "fixable" - it is that none of us has resources/desire to design and implement the fix.
(0020868)
obones (administrator)
2013-12-16 17:05

Suspending

- Issue History
Date Modified Username Field Change
2012-12-26 02:35 leus New Issue
2012-12-26 02:35 leus File Added: test_csv.zip
2012-12-26 02:37 leus Note Added: 0020321
2012-12-26 02:37 leus Issue Monitored: leus
2013-01-15 16:09 obones Note Added: 0020382
2013-01-15 16:09 obones Status new => feedback
2013-01-16 05:30 leus Note Added: 0020394
2013-01-16 05:31 leus Note Added: 0020395
2013-08-31 03:52 Arioch Note Added: 0020608
2013-08-31 03:53 Arioch Relationship added has duplicate 0006149
2013-08-31 03:56 Arioch Note Edited: 0020608
2013-08-31 03:57 Arioch Additional Information Updated
2013-09-02 17:17 leus Note Added: 0020629
2013-09-03 08:17 Arioch Note Added: 0020632
2013-09-03 08:19 Arioch Summary Exception: "CSV string is too long" => Exception: "CSV string is too long" with non-escaped lines containing internal quotes
2013-12-13 11:46 obones Note Added: 0020801
2013-12-13 12:13 Arioch Note Added: 0020807
2013-12-16 17:05 obones Note Added: 0020868
2013-12-16 17:05 obones Status feedback => resolved
2013-12-16 17:05 obones Resolution open => suspended
2013-12-16 17:05 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker