Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006073 [JEDI VCL] 00 JVCL Components minor always 2013-01-22 13:10 2014-12-04 16:25
Reporter a-s-z View Status public  
Assigned To obones
Priority normal Resolution suspended  
Status resolved   Product Version 3.47
Summary 0006073: Missing Package for units using 3rdParty controls from developer express
Description There is no package including some controls/units that depend on the components from developer express.

You have to include the jvcl source path into the project, to compile using e.g. JvDynControlEngineDevExpCx
When using packages, the link process is much faster during development.

The main reason for the package definition is, that I do not include the source path of jvcl into the project. I am including the directories containing the dcu's only, since I am using several third party components and when including some source paths, I will get errors like "compiled with another version of ..." soon.



Additional Information I have attached a package definition containing the missing units.

Use the following steps to integrate the package into the installer:
1. Put XML-File into folder "packages\xml"
2. Add project definition into corresponding project group (e.g. D16 Packages.groupproj) in folder "packages"
3. Call MakePackages.bat in "packages\bin" to generate the project files.
Restart the installer. Now the Package should be visible in the installer.
Tags No tags attached.
Attached Files xml file icon Jv3rdDevEx-R.xml [^] (16,521 bytes) 2013-01-22 13:10

- Relationships

-  Notes
(0020709)
obones (administrator)
2013-12-13 10:39

Please try with the latest JVCL version in GIT (or daily zip), some may have been included. If not, please add them to an existing package rather than create a new package.
(0021093)
obones (administrator)
2014-12-04 16:25

No news, suspending the issue

- Issue History
Date Modified Username Field Change
2013-01-22 13:10 a-s-z New Issue
2013-01-22 13:10 a-s-z File Added: Jv3rdDevEx-R.xml
2013-12-13 10:39 obones Note Added: 0020709
2013-12-13 10:39 obones Status new => feedback
2014-12-04 16:25 obones Note Added: 0021093
2014-12-04 16:25 obones Status feedback => resolved
2014-12-04 16:25 obones Resolution open => suspended
2014-12-04 16:25 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker