Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006085 [JEDI VCL] 00 JVCL Components crash always 2013-02-18 13:23 2015-09-14 13:20
Reporter SGlienke View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006085: TJvWizard.FindNextEnabledPage causes infinite loop in IDE
Description Steps to reproduce:

- place TJvWizard on form
- add page
- set EnableJumpToPage to false
- switch to text view
- switch back -> IDE locks up

This is because of the loop in TJvWizard.FindNextEnabledPage and the extra treatment of csDesigning in TJvWizard.FindNextPage.

The loop in TJvWizard.FindNextEnabledPage should only be executed when csDesigning in ComponentState.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020498)
AHUser (developer)
2013-05-25 14:09

Fixed in svn revision 13516.

- Issue History
Date Modified Username Field Change
2013-02-18 13:23 SGlienke New Issue
2013-05-25 14:09 AHUser Note Added: 0020498
2013-05-25 14:09 AHUser Status new => resolved
2013-05-25 14:09 AHUser Fixed in Version => Daily / SVN
2013-05-25 14:09 AHUser Resolution open => fixed
2013-05-25 14:09 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker