Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006108 [JEDI VCL] 00 JVCL Components major always 2013-03-21 15:14 2013-12-13 10:48
Reporter RHoek View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version Daily / GIT
Summary 0006108: TJvHTButton not respecting 'color' property when painting button
Description I would expect the button to be painted using a background with the color specified by the 'Color' property, even when 'theming' has been enabled.

I don't completely understand the code, but some custom painting using the 'color' property is done, but still the button stays the default button color.

DEMO project has been attached.
Additional Information
Tags No tags attached.
Attached Files zip file icon JVCL BUG - TJvHTButton color.zip [^] (86,030 bytes) 2013-03-21 15:14

- Relationships
duplicate of 0005935resolvedobones TjvImgBtn and TJvHTButton property 'Color' does not work 

-  Notes
(0020455)
RHoek (reporter)
2013-03-21 15:16

This issue is duplicate to http://issuetracker.delphi-jedi.org/view.php?id=5935 [^]

- Issue History
Date Modified Username Field Change
2013-03-21 15:14 RHoek New Issue
2013-03-21 15:14 RHoek File Added: JVCL BUG - TJvHTButton color.zip
2013-03-21 15:16 RHoek Note Added: 0020455
2013-12-13 10:48 obones Relationship added duplicate of 0005935
2013-12-13 10:48 obones Duplicate ID 0 => 5935
2013-12-13 10:48 obones Status new => resolved
2013-12-13 10:48 obones Resolution open => duplicate
2013-12-13 10:48 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker