Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006127 [JEDI VCL] 00 JVCL Components minor always 2013-04-14 03:54 2015-09-14 13:20
Reporter jack_wu View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0006127: TjvOfficeButton Color form position wrong in multiple monitor
Description If a form that contains TJvOfficeButton in a second monitor whose right size out of the Delphi Screen width, the Color form is moved to right edge of the screen when it is opened, no matter where the main form position is.

This is caused by that code in TJvCustomOfficeColorButton.AdjustColorForm() uses Delphi's TSceen().Width to calculate the right edge of monitor.

Delphi's TScreen.Width doesn't reflect the second monotor's width, neigth it reflect the absolute right edge's pixel position.
Additional Information Has not check the 3.47 version yet.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020506)
AHUser (developer)
2013-05-25 15:22

This bug was fixed in svn revision 13493. (2013-15-01).

- Issue History
Date Modified Username Field Change
2013-04-14 03:54 jack_wu New Issue
2013-05-25 15:22 AHUser Note Added: 0020506
2013-05-25 15:22 AHUser Status new => resolved
2013-05-25 15:22 AHUser Fixed in Version => Daily / SVN
2013-05-25 15:22 AHUser Resolution open => fixed
2013-05-25 15:22 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker