Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006129 [JEDI VCL] 00 JVCL Components minor always 2013-04-15 21:10 2014-09-03 11:45
Reporter alquimista View Status public  
Assigned To obones
Priority normal Resolution no change required  
Status resolved   Product Version 3.47
Summary 0006129: JvInterpreter evaluated differently using the GetValue method with point numbers
Description   i'm using decimalseparator:='.'; in delphi 2007.
  In synedit editor write 4.5*2. Evaluation is OK =9
  
   ...............
  JvInterpreterProgram1.Source := SynEdit1.Linetext; //
  JvInterpreterProgram1.Run;
   ..............

using StringGrid add a variable "A" with value 4.5.
in the GetValue method fill value 'A' with the value '4.5'
      if Cmp(Identifier,'A') then value:='4.5'; //point
      Done:=true;

  In synedit editor write A*2. Evaluation is bad =90

if I change the decimal point by the comma works fine.
  if Cmp(Identifier,'A') then value:='4,5'; //comma
      Done:=true;
...............

 Why?
    
 
PS: Sorry for my bad English!!!
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020551)
alquimista (reporter)
2013-07-01 22:29

SOLVED:
value:=Extended(FloattoStr('4.5');
(0020552)
alquimista (reporter)
2013-07-01 23:23

not a bug.
(0020731)
obones (administrator)
2013-12-13 10:55

Please try with the latest JVCL version in GIT (or daily zip) and then send us a zipped file containing the sources of an application showing the issue.

- Issue History
Date Modified Username Field Change
2013-04-15 21:10 alquimista New Issue
2013-07-01 22:29 alquimista Note Added: 0020551
2013-07-01 23:23 alquimista Note Added: 0020552
2013-12-13 10:55 obones Note Added: 0020731
2013-12-13 10:55 obones Status new => feedback
2014-09-03 11:45 obones Status feedback => resolved
2014-09-03 11:45 obones Resolution open => no change required
2014-09-03 11:45 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker