Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006137 [JEDI VCL] 02 Installation major always 2013-05-05 20:49 2013-05-17 16:46
Reporter trident_job View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006137: JCL installer fails with DelphiXE4
Description Trying to install JCL (tested with dailybuild jcl-2.5.0.4813).
Installer compilation failed on 'JclSysUtils.pas' file.

Compiled with DelphiXE4 Architect.
Additional Information Command line trace:

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl>SETLOCAL

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl>pushd "C:\Delphi_Libs
\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\"

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl>SET DELPHIVERSION=

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl>cd install

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>build\dcc32ex
.exe --runtime-package-rtl --runtime-package-vcl --preserve-config -q -w -dJCLIN
STALL -E..\bin -I..\source\include -U..\source\common;..\source\windows JediInst
aller.dpr
Using Delphi 18

Embarcadero Delphi for Win32 compiler version 25.0
Copyright (c) 1983,2013 Embarcadero Technologies, Inc.
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\windows\JclReg
istry.pas(548) Warning: W1000 Symbol 'StrPos' is deprecated: 'Moved to the AnsiS
trings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(3885) Warning: W1000 Symbol 'StrPas' is deprecated: 'Moved to the AnsiSt
rings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(3903) Warning: W1000 Symbol 'StrPas' is deprecated: 'Moved to the AnsiSt
rings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(4750) Warning: W1000 Symbol 'StrPCopy' is deprecated: 'Moved to the Ansi
Strings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(4764) Warning: W1000 Symbol 'StrPCopy' is deprecated: 'Moved to the Ansi
Strings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(4895) Warning: W1000 Symbol 'StrFmt' is deprecated: 'Moved to the AnsiSt
rings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(4916) Warning: W1000 Symbol 'StrFmt' is deprecated: 'Moved to the AnsiSt
rings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysI
nfo.pas(5000) Warning: W1000 Symbol 'StrPCopy' is deprecated: 'Moved to the Ansi
Strings unit'
C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\source\common\JclSysU
tils.pas(2763) Error: E2033 Types of actual and formal var parameters must be id
entical
JclInstall.pas(2017) Fatal: F2063 Could not compile used unit 'JclSysUtils.pas'

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>if ERRORLEVEL
 1 goto FailedCompile

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>echo.


C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>echo.


C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>echo An error
 occured while compiling the installer. Installation aborted.
An error occured while compiling the installer. Installation aborted.

C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>echo.


C:\Delphi_Libs\JVCL347CompleteJCL241-Build4571.old\jcl\jcl\install>pause
Appuyez sur une touche pour continuer...
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020473)
trident_job (reporter)
2013-05-05 20:51

Sorry, the log was for the latest released version (JCL241)

Here is the log for the daily build (jcl-2.5.0.4813):

--------------------------------------------

C:\Delphi_Libs\jcl-2.5.0.4813>SETLOCAL

C:\Delphi_Libs\jcl-2.5.0.4813>pushd "C:\Delphi_Libs\jcl-2.5.0.4813\"

C:\Delphi_Libs\jcl-2.5.0.4813>SET DELPHIVERSION=

C:\Delphi_Libs\jcl-2.5.0.4813>cd install

C:\Delphi_Libs\jcl-2.5.0.4813\install>build\dcc32ex.exe --runtime-package-rtl --
runtime-package-vcl --preserve-config -q -w -dJCLINSTALL -E..\bin -I..\source\in
clude -U..\source\common;..\source\windows JediInstaller.dpr
Using Delphi 18

Embarcadero Delphi for Win32 compiler version 25.0
Copyright (c) 1983,2013 Embarcadero Technologies, Inc.
C:\Delphi_Libs\jcl-2.5.0.4813\source\windows\JclRegistry.pas(548) Warning: W1000
 Symbol 'StrPos' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(3893) Warning: W1000
Symbol 'StrPas' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(3911) Warning: W1000
Symbol 'StrPas' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(4758) Warning: W1000
Symbol 'StrPCopy' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(4772) Warning: W1000
Symbol 'StrPCopy' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(4903) Warning: W1000
Symbol 'StrFmt' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(4924) Warning: W1000
Symbol 'StrFmt' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysInfo.pas(5008) Warning: W1000
Symbol 'StrPCopy' is deprecated: 'Moved to the AnsiStrings unit'
C:\Delphi_Libs\jcl-2.5.0.4813\source\common\JclSysUtils.pas(2763) Error: E2033 T
ypes of actual and formal var parameters must be identical
JclInstall.pas(2020) Fatal: F2063 Could not compile used unit 'JclSysUtils.pas'

C:\Delphi_Libs\jcl-2.5.0.4813\install>if ERRORLEVEL 1 goto FailedCompile

C:\Delphi_Libs\jcl-2.5.0.4813\install>echo.


C:\Delphi_Libs\jcl-2.5.0.4813\install>echo.


C:\Delphi_Libs\jcl-2.5.0.4813\install>echo An error occured while compiling the
installer. Installation aborted.
An error occured while compiling the installer. Installation aborted.

C:\Delphi_Libs\jcl-2.5.0.4813\install>echo.


C:\Delphi_Libs\jcl-2.5.0.4813\install>pause
Appuyez sur une touche pour continuer...
(0020474)
AHUser (developer)
2013-05-05 22:19

There is no XE4 support for the moment.
(0020475)
trident_job (reporter)
2013-05-06 07:55

@AHUser Do you know if someone is working on that ?
I may help to identify / fix XE4 compatibility.
(0020483)
bluish (reporter)
2013-05-15 16:50

Check http://issuetracker.delphi-jedi.org/view.php?id=6135 [^] and http://issuetracker.delphi-jedi.org/view.php?id=6136 [^]
(0020487)
Karlheinz (reporter)
2013-05-15 19:47

Andreas has already updated JCl and JVCl to compile under XE4.
You can download the JCL XE4 version from GITHUB and the JVCL X4 version from SOURCEFORGE.
Both compile fine in XE4. Take care about the JEDI.inc in JVCL because it is at the moment the "old" version. I copied the version from JCL to JVCL and everything was fine.
For more details have a look at the newgroups and the comments from Andreas.
Karlheinz
(0020488)
Karlheinz (reporter)
2013-05-15 19:48

Andreas has already updated JCl and JVCl to compile under XE4.
You can download the JCL XE4 version from GITHUB and the JVCL X4 version from SOURCEFORGE.
Both compile fine in XE4. Take care about the JEDI.inc in JVCL because it is at the moment the "old" version. I copied the version from JCL to JVCL and everything was fine.
For more details have a look at the newgroups and the comments from Andreas.
Karlheinz
(0020489)
trident_job (reporter)
2013-05-15 21:55

@bluish and @ Karlheinz, thx for your help.
I get the latest version : JCL from GITHUB, JVCL from SVN, copy the latest jedi-master content from GITHUB, compiled and it works !

I can continue quietly my development now on the XE4 IDE.
Thx everyone for the help.

- Issue History
Date Modified Username Field Change
2013-05-05 20:49 trident_job New Issue
2013-05-05 20:51 trident_job Note Added: 0020473
2013-05-05 22:19 AHUser Note Added: 0020474
2013-05-06 07:55 trident_job Note Added: 0020475
2013-05-15 16:50 bluish Issue Monitored: bluish
2013-05-15 16:50 bluish Note Added: 0020483
2013-05-15 19:47 Karlheinz Note Added: 0020487
2013-05-15 19:48 Karlheinz Note Added: 0020488
2013-05-15 21:55 trident_job Note Added: 0020489
2013-05-17 16:46 AHUser Status new => resolved
2013-05-17 16:46 AHUser Fixed in Version => Daily / SVN
2013-05-17 16:46 AHUser Resolution open => fixed
2013-05-17 16:46 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker