Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006143 [JEDI VCL] 02 Installation block always 2013-05-23 10:53 2013-05-25 13:30
Reporter bluish View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006143: Error E2250 on JvGnugettext.pas(1017) lanching installer
Description I have RAD Studio XE2 and XE4 installed. I successfully installed JCL (latest version from GitHub).
But when I launch install.bat for JVCL (latest version from SourceForge), I get:



[Compiling installer...]
Using Delphi 18

Embarcadero Delphi for Win32 compiler version 25.0
Copyright (c) 1983,2013 Embarcadero Technologies, Inc.
C:\RADComponent\jvcl\run\JvGnugettext.pas(620) Warning: W1000 Symbol 'MidStr' is deprecated: 'Moved to the AnsiStrings unit'
C:\RADComponent\jvcl\run\JvGnugettext.pas(1017) Error: E2250 There is no overloaded version of 'EnumResourceModules' that can be called with these arguments
C:\RADComponent\jvcl\run\JvGnugettext.pas(2756) Warning: W1000 Symbol 'Seek' is deprecated
C:\RADComponent\jvcl\run\JvGnugettext.pas(3186) Warning: W1000 Symbol 'Seek' is deprecated
JVCLInstall.dpr(1918) Fatal: F2063 Could not compile used unit 'JvGnugettext.pas'

Failed to compile JVCL installer
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020491)
bluish (reporter)
2013-05-23 14:28

Also note that I had to download jedi.inc and kylix.inc from https://github.com/project-jedi/jedi [^] and put them in C:\jedi\jvcl\common\jedi because they where missing.
(0020492)
AHUser (developer)
2013-05-23 18:27

Where did you get the JVCL version?

The line "Using Delphi 18" tells me that you didn't use the SVN head revision of the JVCL because that one would print "Using Embarcadero RAD Studio XE4".
(0020494)
bluish (reporter)
2013-05-24 11:20

I downloaded this: http://sourceforge.net/projects/jvcl/files/latest/download [^]
which is: http://heanet.dl.sourceforge.net/project/jvcl/JVCL%203/JVCL%203.47/JVCL347CompleteJCL241-Build4571.zip [^]

But now from your message I deduced I have to checkout the SVN repository https://jvcl.svn.sourceforge.net/svnroot/jvcl/trunk/jvcl [^] (revision 13515).

Then I also copied new version of jedi.inc from JCL, like I said in my first note.
And now it works. Thanks!

- Issue History
Date Modified Username Field Change
2013-05-23 10:53 bluish New Issue
2013-05-23 11:01 bluish Issue Monitored: bluish
2013-05-23 14:28 bluish Note Added: 0020491
2013-05-23 18:27 AHUser Note Added: 0020492
2013-05-23 18:27 AHUser Assigned To => AHUser
2013-05-23 18:27 AHUser Status new => feedback
2013-05-24 11:20 bluish Note Added: 0020494
2013-05-25 13:30 AHUser Status feedback => resolved
2013-05-25 13:30 AHUser Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker