Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006188 [JEDI VCL] 00 JVCL Components minor always 2013-08-20 16:49 2013-12-16 17:07
Reporter Nazgul View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.47
Summary 0006188: Paint problems in TJvPopupMenu with TJvXPMenuPainter
Description I'm experimenting with TJvPopupMenu as a replacement for TPopupMenu, since TPopup menu doesn't allow changing the font. However I have experienced the following problem. Check the attached picture.

The width of the left column is varible. When i move mouse over it, sometimes it's wide, sometimes it's narrow.

This happens even when I remove TJvXPMenuPainter and set JvPopupMenu.Style := mxXP
Additional Information I am using Delphi XE on Windows 8 64 bit. It's reproducible on Windows XP.
Tags No tags attached.
Attached Files png file icon Screenshot.png [^] (16,862 bytes) 2013-08-20 16:49

- Relationships

-  Notes
(0020738)
obones (administrator)
2013-12-13 11:01

Please try with the latest JVCL version in GIT (or daily zip) and then send us a zipped file containing the sources of an application showing the issue.
(0020790)
Nazgul (reporter)
2013-12-13 11:33

I have already removed TJvPopupMenu from our project, and wrote my own menu.

- Issue History
Date Modified Username Field Change
2013-08-20 16:49 Nazgul New Issue
2013-08-20 16:49 Nazgul File Added: Screenshot.png
2013-12-13 11:01 obones Note Added: 0020738
2013-12-13 11:01 obones Status new => feedback
2013-12-13 11:33 Nazgul Note Added: 0020790
2013-12-16 17:07 obones Status feedback => resolved
2013-12-16 17:07 obones Resolution open => unable to reproduce
2013-12-16 17:07 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker