Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006189 [JEDI VCL] 00 JVCL Components major always 2013-08-21 12:36 2013-08-24 21:19
Reporter bugmenot View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006189: AppStorage's WriteStringList and DeleteSubTree raises Invalid pointer operation
Description There is a problem in AppStorage component from JVCL 3.47. When I'm trying to call these functions I have error "Invalid pointer operation":

AppStorage.WriteStringList(Path, SL);
AppStorage.DeleteSubTree(Name);

JVCL 3.45 doesn't contain such issue.
BTW calling ReadStringList from JVCL 3.47 doesn't raise exception.
Additional Information Using Delphi XE2

Tested JVCL versions:
JVCL345CompleteJCL231 works with no problems
JVCL347CompleteJCL241-Build4571 returns "Invalid pointer operation"

Component with demo is attached, just build using version 3.47 and try to remove any configuration.
Tags JvAppXMLFileStorage
Attached Files 7z file icon JvMultiConf_with_Demo.7z [^] (71,667 bytes) 2013-08-21 12:36

- Relationships

-  Notes
(0020587)
bugmenot (reporter)
2013-08-21 12:40

TJvAppXMLFileStorage was used as AppStorage
(0020596)
jfudickar (developer)
2013-08-24 18:34

What must be done to reproduce the error.

I have the demo running, but I've can't reproduce the error.

Could you try to use the lastest daily build or GIT revision?

Regards
Jens
(0020599)
bugmenot (reporter)
2013-08-24 20:58

The problem is in deleting config, but now I see that the problem is not present in daily build, so close it please and don't worry anymore. Thanks!

- Issue History
Date Modified Username Field Change
2013-08-21 12:36 bugmenot New Issue
2013-08-21 12:36 bugmenot File Added: JvMultiConf_with_Demo.7z
2013-08-21 12:40 bugmenot Note Added: 0020587
2013-08-21 12:41 bugmenot Tag Attached: JvAppXMLFileStorage
2013-08-24 18:34 jfudickar Note Added: 0020596
2013-08-24 18:34 jfudickar Status new => feedback
2013-08-24 20:58 bugmenot Note Added: 0020599
2013-08-24 21:19 jfudickar Status feedback => resolved
2013-08-24 21:19 jfudickar Resolution open => fixed
2013-08-24 21:19 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker