Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006194 [JEDI VCL] 02 Installation minor always 2013-08-29 06:58 2013-12-13 11:03
Reporter Goaul View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version Daily / GIT
Summary 0006194: Failure to create Bpl\Win64\JvCore180.bpl when installing on XE4 Win7x64 in virtualbox
Description Im setting up virtualbox w7 64bit environment with Delphi XE4. Daily JCL installed fine, but JVCL install gave this:

Windows 7 Ultimate Service Pack 1 (6.1.7601)

JVCL 3.48.0.0

[Generating: Packages]
Generating packages for D18_x64
    Loaded template.dpk
    Loaded template.dproj
    Loaded template.rc
[Compiling: Packages]
[Compiling: JvCore180.bpl]
Embarcadero Delphi for Win64 compiler version 25.0
Copyright (c) 1983,2013 Embarcadero Technologies, Inc.

Fatal: F2039 Could not create output file 'C:\Users\w64\Documents\RAD Studio\11.0\Bpl\Win64\JvCore180.bpl'
Additional Information Retested it on my host machine with w7 64bit and Delphi XE2 and works fine.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020601)
Goaul (reporter)
2013-08-29 17:23

resolved bu manually creating "Bpl\Win64\" dirs in "C:\Users\w64\Documents\RAD Studio\11.0\". i wonder why it couldnt do it.
(0020602)
Arioch (developer)
2013-08-30 23:36
edited on: 2013-08-30 23:39

try either in xe4 in usual environment or xe2 in virtual environment - there is no reason to expect dependency on virtual box or anything.

Delphi version, missed update packs (btw which are installed in compared xe2 and xe4?), different Windows versions or settings - whatever. But any virtual machine is the most improbable reason ever.
---

> i wonder why it couldnt do it.

1. Reproduce.
2. Track this using SysInternals Process Monitor
3. Execute installer from within IDE and see what is happening

My bet would be that BPL path was wrong in attmempt of creation, like if "$(xxxx)" macro not expanded.

I saw somethign similar in XE2 as i very vaguely remember and it was fixed by explicilty (without nay macros) specifying the bpl output path


- Issue History
Date Modified Username Field Change
2013-08-29 06:58 Goaul New Issue
2013-08-29 17:23 Goaul Note Added: 0020601
2013-08-30 23:36 Arioch Note Added: 0020602
2013-08-30 23:38 Arioch Summary Installing on virtualbox => Failure to create Bpl\Win64\JvCore180.bpl when installing on XE4 Win7x64 in virtualbox
2013-08-30 23:39 Arioch Note Edited: 0020602
2013-12-13 11:03 obones Status new => resolved
2013-12-13 11:03 obones Resolution open => unable to reproduce
2013-12-13 11:03 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker