Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006206 [JEDI VCL] 00 JVCL Components minor always 2013-10-01 16:51 2015-09-14 13:20
Reporter xalo View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006206: TJvCsvDataset.locate fails when loPartialKey and cursor is not positioned
Description When locate is called with loPartialKey Option, fails with ...EVariantInvalidArgError with message 'Invalid argument'... (the same error occurs using TJvDBFindEdit)
Another issue is if you call locate with no Options, it works and returns true if the value is located, but cursor is not positioned in the record.
I've attached an example with the issues.
Additional Information
Tags No tags attached.
Attached Files rar file icon csv.rar [^] (3,544 bytes) 2013-10-01 16:51

- Relationships

-  Notes
(0020837)
obones (administrator)
2013-12-13 16:47

Please try again with the GIT/Daily version, I cannot reproduce the issue.
(0020938)
AHUser (developer)
2014-03-28 20:28

Fixed in master branch

- Issue History
Date Modified Username Field Change
2013-10-01 16:51 xalo New Issue
2013-10-01 16:51 xalo File Added: csv.rar
2013-12-13 11:06 obones Status new => acknowledged
2013-12-13 16:47 obones Note Added: 0020837
2013-12-13 16:47 obones Status acknowledged => feedback
2014-03-28 20:28 AHUser Note Added: 0020938
2014-03-28 20:28 AHUser Status feedback => resolved
2014-03-28 20:28 AHUser Fixed in Version => Daily / GIT
2014-03-28 20:28 AHUser Resolution open => fixed
2014-03-28 20:28 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker