Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006224 [JEDI VCL] 00 JVCL Components feature always 2013-11-14 08:06 2015-09-14 13:20
Reporter tbd View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.45
Summary 0006224: TJvCustomDBComboBox.UpdateDropDownItems additional (e.g. UseDisplayText) property
Description I wanted to use TJvCustomDBComboBox.UpdateDropDownItems method but unfortunately it was not good for me in that case because this method uses LDisplayField.AsString in all cases.

I think it will be useful if I can use LDisplayField.DisplayText also depending on a new property in ListSettings (TJvDBComboBox) options.

Current code:
TJvCustomDBComboBox.UpdateDropDownItems;
...
Line 836: Items.Add(LDisplayField.AsString);
Line 837: Values.Add(LKeyField.AsString);
...

New code:
TJvCustomDBComboBox.UpdateDropDownItems;
...
if UseDisplayText then
  Items.Add(LDisplayField.DisplayText)
else
  Items.Add(LDisplayField.AsString);
...

Thanks.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020700)
AHUser (developer)
2013-12-01 11:14

Added to master branch: TJvDBComboBox.ListSettings.UseDisplayText default False

- Issue History
Date Modified Username Field Change
2013-11-14 08:06 tbd New Issue
2013-12-01 11:14 AHUser Note Added: 0020700
2013-12-01 11:14 AHUser Status new => resolved
2013-12-01 11:14 AHUser Fixed in Version => Daily / SVN
2013-12-01 11:14 AHUser Resolution open => fixed
2013-12-01 11:14 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker