Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006239 [JEDI VCL] 03 Donations feature always 2013-12-13 20:35 2015-09-14 13:20
Reporter sambo View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0006239: Continuation from issue id 0005793 -- allow strings in TJvSpinEdits
Description I cannot seem to reopen issue 0005793 (which by the way unintentionally fell through the cracks -- I didn't mean to let it dies off.)

Anyway, I have reproduced the same demo on DelphiXE3 (which is our current dev environment) and the spins edits show correctly still, with text, as intended.

Additional Information To address your comment about the code going into TJvCustomSpinEdit: it seems to me that the new value type vtString is as generic as the other types (vtInteger, vtHex, etc...) so to make a distinction between them will make the code unnecessarily messy (especially for the GetValue routine, which TJvCustomSpinEdit doesn't actually implement but rather inherits.)

I'm totally puzzled as to why you'd see integers instead of strings in the demo, and I have to assume that there was some sort of patch glitch. I've seen stuff go bad before due to line-ending changes in the diff and/or source files. Perhaps the patch I produced has the wrong line-endings (I produced it on Linux.)

To that end I'm attaching my version of the before and after JvSpin.pas files and you can diff-and-patch in a way that you know works properly for you.

The demo from the original 0005793 issue can be used as is.

Please let me know whether you were able to run the demo correctly or not.

Thanks!
  S.
Tags No tags attached.
Attached Files zip file icon JvSpins.zip [^] (34,499 bytes) 2013-12-13 20:35

- Relationships
related to 0005793resolvedobones JvSpin does not allow strings 

-  Notes
(0020866)
obones (administrator)
2013-12-16 14:37

Well, I tried again, and still the same diff.
But looking at the code in more details and debugging it, I found that it was missing the change in TJvSpinEdit.SetValue
Once I added the appropriate code here, I was able to have text and work with it in the spin edit.
This has been commited in GIT.

- Issue History
Date Modified Username Field Change
2013-12-13 20:35 sambo New Issue
2013-12-13 20:35 sambo File Added: JvSpins.zip
2013-12-16 09:56 obones Status new => acknowledged
2013-12-16 09:57 obones Relationship added related to 0005793
2013-12-16 14:37 obones Note Added: 0020866
2013-12-16 14:37 obones Status acknowledged => resolved
2013-12-16 14:37 obones Fixed in Version => Daily / GIT
2013-12-16 14:37 obones Resolution open => fixed
2013-12-16 14:37 obones Assigned To => obones
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker