Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006270 [JEDI VCL] 00 JVCL Components major always 2014-03-25 20:54 2015-09-14 13:20
Reporter warmbooter View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006270: FileList items being populated twice
Description If you have a JvDirectoryListBox linked to a JvFileList, when you change to a directory containing files that matches the mask of the linked FileList, the items in the FileList are populated twice. This is because TJvFileListBox.SetDirectory calls the inherited ApplyFilePath that already populates the FileList, and after that it calls ReadFileNames, that populates FileList again! Solution seems to be commenting the call to ReadFileNames.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020933)
AHUser (developer)
2014-03-27 21:35

Fixed in master branch

- Issue History
Date Modified Username Field Change
2014-03-25 20:54 warmbooter New Issue
2014-03-27 21:35 AHUser Note Added: 0020933
2014-03-27 21:35 AHUser Status new => resolved
2014-03-27 21:35 AHUser Fixed in Version => Daily / GIT
2014-03-27 21:35 AHUser Resolution open => fixed
2014-03-27 21:35 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker