Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006271 [JEDI VCL] 00 JVCL Components minor always 2014-03-31 18:27 2015-09-14 13:20
Reporter Francisco1982 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006271: Error using JVBalloonHint with Application Style in Delphi XE4
Description I tried using a component with a style JVBalloonHint Delphi XE4 but that did not work. Showed a strange track on the screen as if Beyond that show the balloon but instead unconfigures to display itself.
I used the Delphi XE4, Application Style Carbon and JVCL 3.47.
Additional Information
Tags No tags attached.
Attached Files png file icon teste_jvBalloonHint.png [^] (3,091 bytes) 2014-03-31 18:27
png file icon fig1-silver.png [^] (28,384 bytes) 2014-04-02 02:07
png file icon fig3-carbon.png [^] (21,592 bytes) 2014-04-02 02:07
png file icon fig1-windows.png [^] (33,141 bytes) 2014-04-02 02:08

- Relationships

-  Notes
(0020941)
leobruno (reporter)
2014-04-02 02:07

I have the same ISSUE with XE3
(0020942)
leobruno (reporter)
2014-04-02 02:10

I have upladed 3 files:

fig1-Silver, depicts the issue with the style SILVER.
fig3-carbon, the same test with the style CARBON
fig1-windows, the test with the standard windows style
(0020943)
AHUser (developer)
2014-04-02 20:09

The BalloonHint now always uses the system's theme because VCL Styles don't implement the required painting functions for BallonHints.

- Issue History
Date Modified Username Field Change
2014-03-31 18:27 Francisco1982 New Issue
2014-03-31 18:27 Francisco1982 File Added: teste_jvBalloonHint.png
2014-04-02 02:07 leobruno Note Added: 0020941
2014-04-02 02:07 leobruno File Added: fig1-silver.png
2014-04-02 02:07 leobruno File Added: fig3-carbon.png
2014-04-02 02:08 leobruno File Added: fig1-windows.png
2014-04-02 02:10 leobruno Note Added: 0020942
2014-04-02 02:10 leobruno Issue Monitored: leobruno
2014-04-02 20:09 AHUser Note Added: 0020943
2014-04-02 20:09 AHUser Status new => resolved
2014-04-02 20:09 AHUser Fixed in Version => Daily / GIT
2014-04-02 20:09 AHUser Resolution open => fixed
2014-04-02 20:09 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker