Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006279 [JEDI VCL] 00 JVCL Components minor always 2014-05-03 15:41 2015-09-14 13:20
Reporter leobruno View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006279: TJvStandardPage appearence with application styles
Description In delphi XE3 changing the aplication style will not affect TJvStandardPage style.

See the attached print.

The attached print depicts the CARBON Style in a form with TJvStandardPage
Additional Information
Tags No tags attached.
Attached Files png file icon print.png [^] (153,946 bytes) 2014-05-03 15:41

- Relationships

-  Notes
(0020994)
johncohen (reporter)
2014-06-06 02:17

Same thing here.
I guess that it has to do with the painters.
(0020995)
johncohen (reporter)
2014-06-06 04:36

John, I´m with you !

Jedi Crew, should we expect this issue to be solved ?
(0020996)
AHUser (developer)
2014-06-06 19:23

Looks like nobody of the "Jedi Crew" is using Custom Styles. I would even go as far as saying that this is a VCL-Styles bug which doesn't hook GetSysColor with StyleServices.GetSystemStyle. clBtnFace becomes the color that the native Windows style defines because GetSysColor returns the native Windows style what doesn't equals the StyleServices.GetSystemColor for clBtnFace (the one that you want).

This should be fixed now as JvThemes.DrawThemedBackground calls StyleServices.GetSystemColor explicitly. But I don't know what other JVCL components are affected by this. Only those that call DrawThemedBackground are fixed.

- Issue History
Date Modified Username Field Change
2014-05-03 15:41 leobruno New Issue
2014-05-03 15:41 leobruno File Added: print.png
2014-06-06 02:17 johncohen Note Added: 0020994
2014-06-06 04:36 johncohen Note Added: 0020995
2014-06-06 19:23 AHUser Note Added: 0020996
2014-06-06 19:23 AHUser Status new => resolved
2014-06-06 19:23 AHUser Fixed in Version => Daily / GIT
2014-06-06 19:23 AHUser Resolution open => fixed
2014-06-06 19:23 AHUser Assigned To => AHUser
2015-09-14 13:20 obones Fixed in Version Daily / GIT => 3.48


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker