Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006280 [JEDI VCL] 00 JVCL Components minor always 2014-05-07 18:47 2015-09-21 17:47
Reporter lomo74 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006280: TJvOutlookBar draws button highlight incorrectly when a page has ParentFont = False and different font size
Description When a TJvOutlookBar page has ParentFont = False and a font size that is different from that of the TJvOutlookBar component itself, button highlight rects (starting at the second button) are drawn incorrectly.
This is because TJvCustomOutlookBar.GetTextHeight calculates the button caption's height according to the main component's font, instead of the page's font.
Patch attached.
Additional Information
Tags No tags attached.
Attached Files txt file icon patch.txt [^] (855 bytes) 2014-05-07 18:47
zip file icon issue6280.zip [^] (577,983 bytes) 2014-09-03 12:10
txt file icon patch1.txt [^] (1,389 bytes) 2014-09-03 13:53

- Relationships

-  Notes
(0021028)
obones (administrator)
2014-09-03 11:36

Please provide the zipped sources of a sample application showing this
(0021043)
lomo74 (reporter)
2014-09-03 13:48

Sorry, I reviewed my patch.
The originally submitted solution was buggy and was the cause of a subsequent issue (# 6281).

- Issue History
Date Modified Username Field Change
2014-05-07 18:47 lomo74 New Issue
2014-05-07 18:47 lomo74 File Added: patch.txt
2014-09-03 11:36 obones Note Added: 0021028
2014-09-03 11:36 obones Status new => feedback
2014-09-03 12:10 lomo74 File Added: issue6280.zip
2014-09-03 13:48 lomo74 Note Added: 0021043
2014-09-03 13:53 lomo74 File Added: patch1.txt
2014-10-01 10:49 AHUser Status feedback => resolved
2014-10-01 10:49 AHUser Fixed in Version => Daily / GIT
2014-10-01 10:49 AHUser Resolution open => fixed
2014-10-01 10:49 AHUser Assigned To => AHUser
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker