Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006282 [JEDI VCL] 02 Installation block always 2014-05-11 13:34 2015-09-21 17:47
Reporter Philippe Paternotte View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006282: JVCL348 Build 5178 - JCL installer fails to execute
Description Compilation was successful using XE6 but then JediInstaller crashes with EJclBorRADException: Query of RsVars for RAD Studio 14 reported the following error "".
Additional Information Under XP SP3, started with a fresh 5178 unzip.
with D2006 Architect, XE4 Pro & XE6 Pro installed.
JCL/JVCL was previously successfully installed for D2006 & XE4 and not uninstalled.
XE6 was fresh, never used.
Launched jcl\install.bat
French system & XE installations.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020959)
Philippe Paternotte (reporter)
2014-05-13 10:35

Update: I've managed to recompile the installer with XE4. It starts, installs well for D2006 & XE4 but fails to install into XE6 with the same exception.
(0020960)
AHUser (developer)
2014-05-14 18:32

What is the content of the "rsvars.bat" file in $(XE6-BDS)\bin ?
(0020961)
Philippe Paternotte (reporter)
2014-05-14 20:11

Here it is:

@SET BDS=C:\Program Files\Embarcadero\Studio\14.0
@SET BDSINCLUDE=C:\Program Files\Embarcadero\Studio\14.0\include
@SET BDSCOMMONDIR=C:\Documents and Settings\All Users\Documents\Embarcadero\Studio\14.0
@SET FrameworkDir=C:\WINDOWS\Microsoft.NET\Framework\v3.5
@SET FrameworkVersion=v3.5
@SET FrameworkSDKDir=
@SET PATH=%FrameworkDir%;%FrameworkSDKDir%;C:\Program Files\Embarcadero\Studio\14.0\bin;C:\Program Files\Embarcadero\Studio\14.0\bin64;C:\Documents and Settings\All Users\Documents\Embarcadero\InterBase\redist\InterBaseXE3\win32_togo;C:\Documents and Settings\All Users\Documents\Embarcadero\InterBase\redist\InterBaseXE3\win64_togo;%PATH%
@SET LANGDIR=FR
@SET PLATFORM=
@SET PlatformSDK=
(0020962)
AHUser (developer)
2014-05-14 22:21

The file seems to be ok.

I have changed the JCL installer's code to not execute '%COMSPEC% /C " call rsvars.bat && set " ' but to parse the file (what is even faster and more reliable).

The changes are in the git master branch.
(0020963)
Philippe Paternotte (reporter)
2014-05-15 06:59

OK it has fixed the problem.

- Issue History
Date Modified Username Field Change
2014-05-11 13:34 Philippe Paternotte New Issue
2014-05-13 10:35 Philippe Paternotte Note Added: 0020959
2014-05-14 18:32 AHUser Note Added: 0020960
2014-05-14 20:11 Philippe Paternotte Note Added: 0020961
2014-05-14 22:21 AHUser Note Added: 0020962
2014-05-14 22:21 AHUser Assigned To => AHUser
2014-05-14 22:21 AHUser Status new => feedback
2014-05-15 06:59 Philippe Paternotte Note Added: 0020963
2014-05-16 20:49 AHUser Status feedback => resolved
2014-05-16 20:49 AHUser Fixed in Version => Daily / GIT
2014-05-16 20:49 AHUser Resolution open => fixed
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker