Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006307 [JEDI VCL] 00 JVCL Components major always 2014-07-22 17:36 2014-08-31 22:40
Reporter ricolebo View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version 3.47
Summary 0006307: TJvBalloonHint NOT painting on Windows WIN8 and DEX5
Description I use Version 3.48

Just complile project BalloonPrj.dproj in folder examples\JvBalloonHint\. on DEX5 and WIN8 to see the bug


Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0006297resolvedobones TJvBalloonHint NOT painting on Windows 7 / 8 
related to 0005258resolvedobones TJvBalloonHint NOT painting on Windows 7 

-  Notes
(0021006)
ricolebo (reporter)
2014-07-22 18:04

Problem saw and fixed in this topic http://issuetracker.delphi-jedi.org/view.php?id=5258 [^]

But Not fixed in 3.48 ...
May be the fix was lost

It works with this code (I added the previous fix) :

procedure TJvBalloonWindow.CreateParams(var Params: TCreateParams);
begin
  inherited CreateParams(Params);
  { Drop shadow in combination with custom animation may cause blurry effect,
    no solution.
  }
  with Params do
  begin
    Style := Style and not WS_BORDER;
    if IsWinXP_UP and (GetComCtlVersion >= ComCtlVersionIE6) then
    begin
      WindowClass.Style := WindowClass.Style or CS_DROPSHADOW;
      {$IFDEF JVCLThemesEnabled}
      if Not IsWinSeven_UP and IsWinVista_UP and StyleServices.Enabled then
      begin
        ExStyle := ExStyle or WS_EX_LAYERED;
        if FIsMultiLineMsg then
          ExStyle := ExStyle or WS_EX_COMPOSITED;
      end;
      {$ENDIF JVCLThemesEnabled}
    end
    else
      WindowClass.Style := WindowClass.Style and not CS_DROPSHADOW;
  end;
end;
(0021019)
obones (administrator)
2014-08-31 22:40

Duplicate

- Issue History
Date Modified Username Field Change
2014-07-22 17:36 ricolebo New Issue
2014-07-22 18:04 ricolebo Note Added: 0021006
2014-08-31 22:39 obones Relationship added related to 0005258
2014-08-31 22:39 obones Assigned To => obones
2014-08-31 22:40 obones Note Added: 0021019
2014-08-31 22:40 obones Relationship added duplicate of 0006297
2014-08-31 22:40 obones Duplicate ID 0 => 6297
2014-08-31 22:40 obones Status new => resolved
2014-08-31 22:40 obones Resolution open => duplicate


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker