Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006331 [JEDI VCL] 00 JVCL Components major N/A 2014-09-30 10:58 2015-09-21 17:47
Reporter davidheffernan View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006331: VFW header translation incorrectly uses packed records
Description The vfw.h header translation found in VFW.pas declares the records as packed. This is incorrect. There is no #pragma(pack) in vfw.h. Under 32 bit you probably get away with this because most fields are 4 bytes wide. But under 64 bit the pointers are 8 bytes wide and there will be padding.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021061)
AHUser (developer)
2014-10-01 09:54

Fixed in 855898d4eb1cbc2fc9871abecf0595cc9bb68008

- Issue History
Date Modified Username Field Change
2014-09-30 10:58 davidheffernan New Issue
2014-10-01 09:54 AHUser Issue Monitored: AHUser
2014-10-01 09:54 AHUser Issue End Monitor: AHUser
2014-10-01 09:54 AHUser Note Added: 0021061
2014-10-01 09:54 AHUser Status new => resolved
2014-10-01 09:54 AHUser Fixed in Version => Daily / GIT
2014-10-01 09:54 AHUser Resolution open => fixed
2014-10-01 09:54 AHUser Assigned To => AHUser
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker