Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006333 [JEDI VCL] 00 JVCL Components minor always 2014-10-03 20:16 2014-12-04 15:49
Reporter boerema1 View Status public  
Assigned To obones
Priority normal Resolution no change required  
Status resolved   Product Version 3.47
Summary 0006333: TJvBalloonHint as Application Hint causes second form on taskbar to hide below first
Description When using TJvBalloonHint and setting UseBalloonAsApplicationHint to true and then creating a secondary form that shows on the taskbar (adding WS_EX_APPWINDOW), then as soon as the hint balloon pops up the secondary form moves below the main form.

See the attached example project that shows the problem.

I think the problem is inside TJvBalloonWindowEx.EnsureTopMost but not sure exactly what to do about it.
Additional Information
Tags No tags attached.
Attached Files zip file icon JvBalloonHintTest.zip [^] (2,389 bytes) 2014-10-03 20:16

- Relationships

-  Notes
(0021087)
obones (administrator)
2014-12-04 15:49

You must add this in your project sources:

  Application.MainFormOnTaskBar := True;

- Issue History
Date Modified Username Field Change
2014-10-03 20:16 boerema1 New Issue
2014-10-03 20:16 boerema1 File Added: JvBalloonHintTest.zip
2014-12-04 15:01 obones Status new => acknowledged
2014-12-04 15:49 obones Note Added: 0021087
2014-12-04 15:49 obones Status acknowledged => resolved
2014-12-04 15:49 obones Resolution open => no change required
2014-12-04 15:49 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker