Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006371 [JEDI VCL] General API minor always 2014-12-13 04:51 2016-08-07 16:19
Reporter Michal Mucha View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0006371: Installation issues. Concerns all XE6 and XE7 compilers
Description In my previous issue report (0006369) I indicated missing component in XE7 IDE.
Actually, as I found later there were more missing components
from 'Jv Persistence' tab on the components palette/list.
I did not check the other components tabs.
All the missing ones were registered in the same function call

RegisterComponents(RsPalettePersistence, [TJvFormStorage,
  TJvFormStorageSelectList, TJvAppXMLFileStorage]);

in the JvSystemReg.pas.
My conjecture was that something must be wrong or missing in project
files so the linker or component installer in the IDE does not "see"
the necessary files.
During the search found that all dproj files for XE6 (d20) and XE7 (d21)
packages have wrong paths in sections

    <PropertyGroup Condition="'$(Cfg_1)'!=''">
        <DCC_LocalDebugSymbols>false</DCC_LocalDebugSymbols>
        <DCC_Define>RELEASE;$(DCC_Define)</DCC_Define>
        <DCC_DebugInformation>0</DCC_DebugInformation>
        <DCC_UnitSearchPath>..\..\lib\d19\win32;$(DCC_UnitSearchPath)</DCC_UnitSearchPath>
        <DCC_DcpOutput>..\..\lib\d19\win32</DCC_DcpOutput>
        <DCC_DcuOutput>..\..\lib\d19\win32</DCC_DcuOutput>
        <DCC_Namespace>System;System.Win;WinApi;Vcl;Vcl.Imaging;Data;Data.Win;$(DCC_Namespace)</DCC_Namespace>
    </PropertyGroup>
    <PropertyGroup Condition="'$(Cfg_2)'!=''">
        <DCC_Define>DEBUG;$(DCC_Define)</DCC_Define>
        <DCC_SymbolReferenceInfo>2</DCC_SymbolReferenceInfo>
        <DCC_UnitSearchPath>..\..\lib\d19\win32\debug;$(DCC_UnitSearchPath)</DCC_UnitSearchPath>
        <DCC_DcpOutput>..\..\lib\d19\win32\debug</DCC_DcpOutput>
        <DCC_DcuOutput>..\..\lib\d19\win32\debug</DCC_DcuOutput>
        <DCC_Namespace>System;System.Win;WinApi;Vcl;Vcl.Imaging;Data;Data.Win;$(DCC_Namespace)</DCC_Namespace>
    </PropertyGroup>
Obviously, one would expect it to be \lib\d20 and \lib\d21 for XE6 and XE7 respectively.
I traced the problem to template.dproj files for these packages. Most probably the wrong
directories were propagated from templates to all other projects by the package generator
program (pg.exe) which uses the templates.

I am not sure if the JVCLInstall.exe makes use of the directories declared in the dproj files
since in my case all the dcu, bpi, dcp, lib files were in the ... \lib\d21\ ... directory.
But in case it does use the information in some place then the problem shoud be addressed
as soon as possible.

I did not manage to rerun the package generator, and the installation procedure yet, so
at the moment I cannot tell if this helped in case of components missing from the palette.

Anyway even if the path \lib\dxx information is irrelevant for the JVCLInstall
it would be a departure from the scheme adopted for earlier versions. I would appreciate
comments from maintainers.

Regards
Michal Mucha
Additional Information
Tags Install
Attached Files

- Relationships

-  Notes
(0021135)
Michal Mucha (reporter)
2014-12-13 18:29

At the moment when I added this issue I could not select proper category.
I should go to JEDI JVCL Install.
(0021352)
AHUser (developer)
2016-08-06 14:06

Fixed in master branch.

- Issue History
Date Modified Username Field Change
2014-12-13 04:51 Michal Mucha New Issue
2014-12-13 04:51 Michal Mucha Status new => assigned
2014-12-13 04:51 Michal Mucha Assigned To => ChristianWimmer
2014-12-13 18:27 Michal Mucha Tag Attached: Install
2014-12-13 18:29 Michal Mucha Note Added: 0021135
2016-08-06 13:46 AHUser Project JEDI API & WSC Library => JEDI VCL
2016-08-06 14:06 AHUser Note Added: 0021352
2016-08-06 14:06 AHUser Status assigned => resolved
2016-08-06 14:06 AHUser Fixed in Version => Daily / GIT
2016-08-06 14:06 AHUser Resolution open => fixed
2016-08-07 16:19 AHUser Assigned To ChristianWimmer =>
2016-08-07 16:19 AHUser Status resolved => feedback
2016-08-07 16:19 AHUser Resolution fixed => reopened
2016-08-07 16:19 AHUser Status feedback => resolved
2016-08-07 16:19 AHUser Resolution reopened => fixed
2016-08-07 16:19 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker