Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006372 [JEDI VCL] 00 JVCL Components feature always 2015-01-05 12:08 2015-09-27 17:15
Reporter CDametto View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006372: Jvrollout appearance with vcl styles
Description I added two properties to jvRollOut to paint it with the current style (if enabled): ButtonStyle and UseGroupBoxCaptionColor.
The first allows you to choose the style as a header or as a button, the second sets the color of the caption like the object GroupBox.
I added a third property to not hide objects on the title when the panel is collapsed: CollapseCtrlsOnButton. This does not work very well because it presents some refreshing problems.
I would appreciate if you would like to implement the option to have these settings in the component.
Thank You
Additional Information I am attaching my modified sources and a little test program.
Tags No tags attached.
Attached Files ? file icon JvRollOut.pas [^] (49,395 bytes) 2015-01-05 12:08
zip file icon Test.zip [^] (3,439,399 bytes) 2015-01-05 12:09

- Relationships

-  Notes
(0021221)
AHUser (developer)
2015-09-27 17:15

Applied to git master branch.

- Issue History
Date Modified Username Field Change
2015-01-05 12:08 CDametto New Issue
2015-01-05 12:08 CDametto File Added: JvRollOut.pas
2015-01-05 12:09 CDametto File Added: Test.zip
2015-01-19 16:01 obones Status new => acknowledged
2015-09-27 17:15 AHUser Note Added: 0021221
2015-09-27 17:15 AHUser Status acknowledged => resolved
2015-09-27 17:15 AHUser Fixed in Version => Daily / GIT
2015-09-27 17:15 AHUser Resolution open => fixed
2015-09-27 17:15 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker