Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006378 [JEDI VCL] 00 JVCL Components minor always 2015-01-25 12:24 2015-09-21 17:47
Reporter Ernst View Status public  
Assigned To obones
Priority normal Resolution unable to reproduce  
Status resolved   Product Version 3.47
Summary 0006378: Error in TJvRichEdit
Description Delphi 7 does not know DWORD_PTR
Delphi 7 does not recognize

 {$IFDEF COMPILER19_UP}DWORD_PTR{$ELSE}Longint{$ENDIF}

ocurrence:
line: 1800
function StreamSave(dwCookie: {$IFDEF COMPILER19_UP}DWORD_PTR{$ELSE}Longint{$ENDIF}; pbBuff: PByte;
  cb: Longint; var pcb: Longint): Longint; stdcall;

line 1960:
function StreamLoad(dwCookie: {$IFDEF COMPILER19_UP}DWORD_PTR{$ELSE}Longint{$ENDIF}; pbBuff: PByte;
  cb: Longint; var pcb: Longint): Longint; stdcall;

line 1971:
function StreamLoadW(dwCookie: {$IFDEF COMPILER19_UP}DWORD_PTR{$ELSE}Longint{$ENDIF}; pbBuff: PByte;
  cb: Longint; var pcb: Longint): Longint; stdcall;

Delphi 7 cannot compile
dwCookie := DWORD_PTR(AConverter)
in line 6013
in procedure TJvRichEditStrings.DoExport(AConverter: TJvConversion);

in line 6065
in procedure TJvRichEditStrings.DoImport(AConverter: TJvConversion);
Additional Information
Tags No tags attached.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2015-01-25 12:24 Ernst New Issue
2015-09-14 11:20 obones Status new => resolved
2015-09-14 11:20 obones Fixed in Version => Daily / GIT
2015-09-14 11:20 obones Resolution open => unable to reproduce
2015-09-14 11:20 obones Assigned To => obones
2015-09-21 17:47 obones Fixed in Version Daily / GIT => 3.49


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker