Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006433 [JEDI VCL] 00 JVCL Components crash always 2015-08-21 12:28 2019-04-27 15:43
Reporter Milan Bacik View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.47
Summary 0006433: TJvCheckedComboBox crash in destructor
Description TJvCheckedComboBox crash when on MDIChild form. It need to be poped up and focused(just after clicked some checkbox). When in this moment form close, TJvCheckedComboBox crashed with this exception: EInvalidopearation with message 'Control 'JvCheckedComboBox1' has no parent window'.
Additional Information Atached simple example in C++ Builder 2010. Just open child form with button. Than open popup in combo and click any checkbox. Now wait for timer which close form. Btw. In my real application form is closed by hitting Esc, which somehow bypased closing poppup first and is catched by button with ModalResult = mrCancel.
Tags No tags attached.
Attached Files zip file icon CheckedComboBox.zip [^] (8,932 bytes) 2015-08-21 12:28
zip file icon CheckedComboBox_delphi.zip [^] (64,339 bytes) 2015-09-14 16:14

- Relationships

-  Notes
(0021202)
obones (administrator)
2015-09-14 16:17

I have attached your sample along with Delphi files which makes for easier debugging.

To me this is an issue in the VCL and have reported it here:
https://quality.embarcadero.com/browse/RSP-12241 [^]
(0021754)
mh (reporter)
2019-04-26 20:47

According to Embarcadero QP this is fixed in Rio and I ran the Delphi demo provided without crash in Rio Update 1.

I clicked the button, got the child form, opened the combo box dropdown and selected a car manufacturer. Waited until the MDI form was closed, closed the program and got no crash at all.

=> looks like this is fixed
(0021768)
jfudickar (developer)
2019-04-27 15:43

Fixed in Rio

- Issue History
Date Modified Username Field Change
2015-08-21 12:28 Milan Bacik New Issue
2015-08-21 12:28 Milan Bacik File Added: CheckedComboBox.zip
2015-09-14 11:27 obones Status new => acknowledged
2015-09-14 16:14 obones File Added: CheckedComboBox_delphi.zip
2015-09-14 16:17 obones Note Added: 0021202
2015-09-14 16:17 obones Status acknowledged => confirmed
2019-04-26 20:47 mh Note Added: 0021754
2019-04-27 15:43 jfudickar Note Added: 0021768
2019-04-27 15:43 jfudickar Status confirmed => resolved
2019-04-27 15:43 jfudickar Resolution open => fixed
2019-04-27 15:43 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker